net-misc/gns3-server: Version Bump to 2.1.21
authorGino McCarty <onigino@protonmail.com>
Sun, 14 Apr 2019 21:05:36 +0000 (14:05 -0700)
committerMichał Górny <mgorny@gentoo.org>
Tue, 16 Jul 2019 12:12:50 +0000 (14:12 +0200)
Signed-off-by: Gino McCarty <onigino@protonmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/gns3-server/Manifest
net-misc/gns3-server/gns3-server-2.1.21.ebuild [new file with mode: 0644]

index 17588ddf425c1009d7049013324b1ff03583307e..a8eab6d583a98a8a538a8170bff0b5c3bcafa95c 100644 (file)
@@ -1 +1,2 @@
+DIST gns3-server-2.1.21.tar.gz 1713993 BLAKE2B 719306e05fd86b22b7413a60eb6fccc0d16a25cc3a34850344124433d0871bce5e85b195386615c1eaebf083295775de4031eee93c477bb8bd07078b839b2ee1 SHA512 3aeb7609f0fad3cf239a4de24affb124b5bed4a3af78c6a6e287a1b771e206c476849a04cf4ab731ce4923ca072d66928068fec5720bc0eb81d6819ed63f71c8
 DIST gns3-server-2.1.3.tar.gz 1658657 BLAKE2B 4ce83aceff8f70f93032b2baafb0dd5c94062b8c431a73b9a83401266ae77f18a4e318651ecd05b789b71c512fc3549d0d1fb95b26fe1fdd23b2953b3367f04c SHA512 df6a98943f893f3d10c16b2a4242869a1407adad56e6c127e6525fe49acefbac9329bf76bc2b16904997985843fdb2b94d03c58f658034ec44763e6d69f7ddaf
diff --git a/net-misc/gns3-server/gns3-server-2.1.21.ebuild b/net-misc/gns3-server/gns3-server-2.1.21.ebuild
new file mode 100644 (file)
index 0000000..aebe519
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 python-utils-r1
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/aiohttp-2.3.3[${PYTHON_USEDEP}]
+       <dev-python/aiohttp-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/aiohttp-cors-0.6.0[${PYTHON_USEDEP}]
+       sys-apps/busybox
+       <dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
+       >=app-emulation/dynamips-0.2.18
+       >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+       dev-python/prompt_toolkit[${PYTHON_USEDEP}]
+       >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/python-zipstream-1.1.4[${PYTHON_USEDEP}]
+       >=dev-python/raven-5.23.0[${PYTHON_USEDEP}]
+       >=net-misc/ubridge-0.9.14
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       default
+
+       #Remove Pre-built busybox binary
+       rm gns3server/compute/docker/resources/bin/busybox || die
+       # Package installs 'tests' package which is forbidden
+       rm -rf tests || die
+}
+
+python_install() {
+       distutils-r1_python_install
+
+       mkdir -p "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin" || die
+       ln -s /bin/busybox "${D}$(python_get_sitedir)/gns3server/compute/docker/resources/bin/busybox" || die
+}
+
+pkg_postinst() {
+       elog "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
+       elog ""
+       elog "The following is a list of packages that can be added:"
+       elog "app-emulation/qemu, app-emulation/virtualbox"
+       elog "app-emulation/docker and net-analyzer/wireshark"
+       elog ""
+       elog "The following packages are currently unsupported:"
+       elog "iouyap and vpcs"
+}