sys-libs/glibc: allow glibc dongrade on I_ALLOW_TO_BREAK_MY_SYSTEM
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 12 Oct 2019 19:49:16 +0000 (20:49 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 12 Oct 2019 20:03:05 +0000 (21:03 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.19-r2.ebuild
sys-libs/glibc/glibc-2.26-r7.ebuild
sys-libs/glibc/glibc-2.27-r6.ebuild
sys-libs/glibc/glibc-2.28-r6.ebuild

index 75f849f69dc267ed07ad462c6a77029251e3ed62..0fedbb8e9409f671e20c5c9300421f84727bda55 100644 (file)
@@ -539,7 +539,7 @@ sanity_prechecks() {
                if has_version ">${CATEGORY}/${P}-r10000" ; then
                        eerror "Sanity check to keep you from breaking your system:"
                        eerror " Downgrading glibc is not supported and a sure way to destruction."
-                       die "Aborting to save your system."
+                       [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
                fi
 
                if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
index bfbe9b01b0334b7d72e63a8e41ec8ed1ec2e2b60..34d8fb8a7ac910da8ecd25ae7efa4cf0253b45d2 100644 (file)
@@ -122,7 +122,7 @@ pkg_pretend() {
                if has_version ">${CATEGORY}/${P}-r10000" ; then
                        eerror "Sanity check to keep you from breaking your system:"
                        eerror " Downgrading glibc is not supported and a sure way to destruction"
-                       die "Aborting to save your system"
+                       [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
                fi
 
                if ! glibc_run_test '#include <pwd.h>\nint main(){return getpwuid(0)==0;}\n'
index 42be8144de45f1025ac27f40d46226d24dc444e2..f1409e36cf34c9f019301c7606107c2a1e7305b0 100644 (file)
@@ -607,7 +607,7 @@ sanity_prechecks() {
                if has_version ">${CATEGORY}/${P}-r10000" ; then
                        eerror "Sanity check to keep you from breaking your system:"
                        eerror " Downgrading glibc is not supported and a sure way to destruction."
-                       die "Aborting to save your system."
+                       [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
                fi
 
                if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
index d40991f16ab9a675e5fc264755626b956234067a..aa318b7e0f1b496c76369cb4fe15dd69b7f9eb40 100644 (file)
@@ -598,7 +598,7 @@ sanity_prechecks() {
                if has_version ">${CATEGORY}/${P}-r10000" ; then
                        eerror "Sanity check to keep you from breaking your system:"
                        eerror " Downgrading glibc is not supported and a sure way to destruction."
-                       die "Aborting to save your system."
+                       [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
                fi
 
                if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then