media-gfx/exiv2: 0.27.2_rc3 version bump for testing
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 21 Jul 2019 15:59:57 +0000 (17:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 21 Jul 2019 16:13:21 +0000 (18:13 +0200)
This is the last RC before 0.27.2 release that is planned for 2019-07-31.

Bug: https://bugs.gentoo.org/689642
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/exiv2/Manifest
media-gfx/exiv2/exiv2-0.27.2_rc3.ebuild [new file with mode: 0644]

index 3db54c1b6ec446b21fa8ccdaa22acef7e6fade0a..b05621e310b339caef4453d08e85e6cd469c96dd 100644 (file)
@@ -1,2 +1,3 @@
 DIST exiv2-0.27.0a-Source.tar.gz 27168207 BLAKE2B 3f5c4fbe4f41c1114c0a54433c810ed0fb28ae3fbe8258eb7a02da716b833d62a94725f839accf22600c420ace5cdbead599440d335ff694a4f123820613ecd9 SHA512 9873d6815c2a87b7cdc49e8863f72c713fe1054f2f46d2c9aaa7ca2cd42096a36c2970e6a396af9000faba32fa9ff054b9d2c5e22f3e2624669440e553239f9c
 DIST exiv2-0.27.1-Source.tar.gz 27210365 BLAKE2B 1ce9a0b26c0908b876e35b5488fc5680789eb864376b379d9bd57977d456a5c6dc5983c4a8ef3e3558ffc061c0b7cda1d1f89a1629af920de1747fd4afbdbb39 SHA512 038b51241f5bfb323eb298695b5397a7d88d5c7d7303828e5e20b3f82c3df2615cee3e7e3426ea17438ca05d5abea10984cfd41f0649ddab72df1d1415bf3529
+DIST exiv2-0.27.2_rc3.tar.gz 27291247 BLAKE2B 72825a50fbafe4eed4ab4a12e135b22bc8a4ef66736dd22794d73e6b1789a3a4da3037dc292948561b7affc33ac1c577ba259b6d4173aa5bd5a640bb7b3dcaef SHA512 3af8ee5f6bc9fcd5e1451ef8750861a79da4aa7c31ceb00d3a659000fc0c939c5adc809b8e37936587212707a8b2b529d30cafce55d35f8baf8eedb1a017e2e6
diff --git a/media-gfx/exiv2/exiv2-0.27.2_rc3.ebuild b/media-gfx/exiv2/exiv2-0.27.2_rc3.ebuild
new file mode 100644 (file)
index 0000000..2adb548
--- /dev/null
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999 ]]; then
+       EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+       inherit git-r3
+else
+#      SRC_URI="https://exiv2.org/builds/${P}-Source.tar.gz"
+       SRC_URI="https://github.com/Exiv2/${PN}/archive/v${PV/_rc/-RC}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+IUSE="doc examples nls +png webready +xmp"
+
+BDEPEND="
+       doc? (
+               ${PYTHON_DEPS}
+               app-doc/doxygen
+               dev-libs/libxslt
+               media-gfx/graphviz
+               virtual/pkgconfig
+       )
+       nls? ( sys-devel/gettext )
+"
+DEPEND="
+       >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+       nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+       png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+       webready? (
+               net-libs/libssh[${MULTILIB_USEDEP}]
+               net-misc/curl[${MULTILIB_USEDEP}]
+       )
+       xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+# S="${S}-Source"
+S="${WORKDIR}/${P/_rc/-RC}"
+
+pkg_setup() {
+       use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       # FIXME @upstream:
+       einfo "Converting doc/cmd.txt to UTF-8"
+       iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+       mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+       cmake-utils_src_prepare
+
+       sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DEXIV2_BUILD_SAMPLES=NO
+               -DEXIV2_BUILD_PO=$(usex nls)
+               -DEXIV2_ENABLE_NLS=$(usex nls)
+               -DEXIV2_ENABLE_PNG=$(usex png)
+               -DEXIV2_ENABLE_CURL=$(usex webready)
+               -DEXIV2_ENABLE_SSH=$(usex webready)
+               -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+               -DEXIV2_ENABLE_XMP=$(usex xmp)
+               $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+               $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+               -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+       )
+
+       cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+       cmake-utils_src_compile
+
+       if multilib_is_native_abi; then
+               use doc && eninja doc
+       fi
+}
+
+multilib_src_install_all() {
+       use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+       einstalldocs
+       find "${D}" -name '*.la' -delete || die
+
+       if use examples; then
+               docinto examples
+               dodoc samples/*.cpp
+       fi
+}