media-plugins/gst-plugins-ivorbis: remove gstreamer 0.10
authorMart Raudsepp <leio@gentoo.org>
Thu, 20 Jun 2019 21:09:09 +0000 (00:09 +0300)
committerMart Raudsepp <leio@gentoo.org>
Thu, 20 Jun 2019 21:27:20 +0000 (00:27 +0300)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-plugins/gst-plugins-ivorbis/Manifest [deleted file]
media-plugins/gst-plugins-ivorbis/files/0.10.36-header-shuffle.patch [deleted file]
media-plugins/gst-plugins-ivorbis/gst-plugins-ivorbis-0.10.36-r1.ebuild [deleted file]
media-plugins/gst-plugins-ivorbis/metadata.xml [deleted file]

diff --git a/media-plugins/gst-plugins-ivorbis/Manifest b/media-plugins/gst-plugins-ivorbis/Manifest
deleted file mode 100644 (file)
index dd87804..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST gst-plugins-base-0.10.36.tar.xz 2364108 BLAKE2B a71ef5d5c7462d60937602681c060e85ed086a753b7ef354dad48354d6c3741d809f2c0c6a321ef9ac60fb12d24ec65e1baa63e51211134d2a5e03aae16f73d2 SHA512 ea77778e073515df58229a641b4363df31f0b80204a5a43a8feb31f0b03a5a4b9b79d6e07e1615c773a59927a9b649f1b1d782def1120d581d09a090be8363b8
diff --git a/media-plugins/gst-plugins-ivorbis/files/0.10.36-header-shuffle.patch b/media-plugins/gst-plugins-ivorbis/files/0.10.36-header-shuffle.patch
deleted file mode 100644 (file)
index 4a1f087..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-Fix build of ivorbis plugin of gstreamer-0.10 series applying header
-code moves from gstreamer-1 series.
-
-The diff can probably be made smaller but the intent was to match
-known working gst-1.
-
-diff -Nu a/ext/vorbis/gstvorbisdeclib.h b/ext/vorbis/gstvorbisdeclib.h
---- a/ext/vorbis/gstvorbisdeclib.h     2011-12-11 19:47:07.000000000 +0100
-+++ b/ext/vorbis/gstvorbisdeclib.h     2013-01-20 18:31:37.291211764 +0100
-@@ -29,11 +29,6 @@
- #ifndef TREMOR
--#include <vorbis/codec.h>
--
--typedef float                          vorbis_sample_t;
--typedef ogg_packet                     ogg_packet_wrapper;
--
- #define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to float audio"
- #define GST_VORBIS_DEC_SRC_CAPS \
-@@ -47,6 +42,42 @@
- #define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstVorbisDec
-+#else /* TREMOR */
-+
-+#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
-+
-+#define GST_VORBIS_DEC_SRC_CAPS \
-+    GST_STATIC_CAPS ("audio/x-raw-int, "   \
-+        "rate = (int) [ 1, MAX ], "        \
-+        "channels = (int) [ 1, 6 ], "      \
-+        "endianness = (int) BYTE_ORDER, "  \
-+        "width = (int) { 16, 32 }, "       \
-+        "depth = (int) 16, "               \
-+        "signed = (boolean) true")
-+
-+#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
-+
-+/* we need a different type name here */
-+#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
-+
-+/* and still have it compile */
-+typedef struct _GstVorbisDec               GstIVorbisDec;
-+typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
-+
-+#endif /* TREMOR */
-+
-+#ifndef USE_TREMOLO
-+
-+#ifdef TREMOR
-+ #include <tremor/ivorbiscodec.h>
-+ typedef ogg_int32_t                    vorbis_sample_t;
-+#else
-+ #include <vorbis/codec.h>
-+ typedef float                          vorbis_sample_t;
-+#endif
-+
-+typedef ogg_packet                     ogg_packet_wrapper;
-+
- static inline guint8 *
- gst_ogg_packet_data (ogg_packet * p)
- {
-@@ -72,17 +103,11 @@
-   return packet;
- }
--#else
--
--#ifdef USE_TREMOLO
--  #include <Tremolo/ivorbiscodec.h>
--  #include <Tremolo/codec_internal.h>
--  typedef ogg_int16_t                    vorbis_sample_t;
--#else
--  #include <tremor/ivorbiscodec.h>
--  typedef ogg_int32_t                    vorbis_sample_t;
--#endif
-+#else /* USE_TREMOLO */
-+#include <Tremolo/ivorbiscodec.h>
-+#include <Tremolo/codec_internal.h>
-+typedef ogg_int16_t                    vorbis_sample_t;
- typedef struct _ogg_packet_wrapper     ogg_packet_wrapper;
- struct _ogg_packet_wrapper {
-@@ -91,26 +116,6 @@
-   ogg_buffer          buf;
- };
--#define GST_VORBIS_DEC_DESCRIPTION "decode raw vorbis streams to integer audio"
--
--#define GST_VORBIS_DEC_SRC_CAPS \
--    GST_STATIC_CAPS ("audio/x-raw-int, "   \
--        "rate = (int) [ 1, MAX ], "        \
--        "channels = (int) [ 1, 6 ], "      \
--        "endianness = (int) BYTE_ORDER, "  \
--        "width = (int) { 16, 32 }, "       \
--        "depth = (int) 16, "               \
--        "signed = (boolean) true")
--
--#define GST_VORBIS_DEC_DEFAULT_SAMPLE_WIDTH           (16)
--
--/* we need a different type name here */
--#define GST_VORBIS_DEC_GLIB_TYPE_NAME      GstIVorbisDec
--
--/* and still have it compile */
--typedef struct _GstVorbisDec               GstIVorbisDec;
--typedef struct _GstVorbisDecClass          GstIVorbisDecClass;
--
- /* compensate minor variation */
- #define vorbis_synthesis(a, b)             vorbis_synthesis (a, b, 1)
-@@ -154,7 +159,7 @@
-   return &(packet->packet);
- }
--#endif
-+#endif /* USE_TREMOLO */
- typedef void (*CopySampleFunc)(vorbis_sample_t *out, vorbis_sample_t **in,
-                            guint samples, gint channels, gint width);
diff --git a/media-plugins/gst-plugins-ivorbis/gst-plugins-ivorbis-0.10.36-r1.ebuild b/media-plugins/gst-plugins-ivorbis/gst-plugins-ivorbis-0.10.36-r1.ebuild
deleted file mode 100644 (file)
index 9dd6e28..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-GST_ORG_MODULE=gst-plugins-base
-inherit gstreamer
-
-KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-fbsd ~x64-macos"
-IUSE=""
-
-RDEPEND=">=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-GST_PLUGINS_BUILD_DIR="vorbis"
-
-src_prepare() {
-       epatch "${FILESDIR}"/0.10.36-header-shuffle.patch
-
-       gstreamer_system_link \
-               gst-libs/gst/audio:gstreamer-audio \
-               gst-libs/gst/tag:gstreamer-tag
-}
diff --git a/media-plugins/gst-plugins-ivorbis/metadata.xml b/media-plugins/gst-plugins-ivorbis/metadata.xml
deleted file mode 100644 (file)
index fb1ea72..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-       <email>gstreamer@gentoo.org</email>
-       <name>GStreamer package maintainers</name>
-</maintainer>
-</pkgmetadata>