dev-python/flask: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 19:33:01 +0000 (21:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 19:33:25 +0000 (21:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flask/Manifest
dev-python/flask/flask-0.12.2.ebuild [deleted file]

index f765872d1fc865b51780246c090973d8368e59ea..e9ecc229b2f4a4f956133661256bcd612def9360 100644 (file)
@@ -1,2 +1 @@
-DIST Flask-0.12.2.tar.gz 548510 BLAKE2B bd92d0e7e6ff36d371ffd958708517d16e41d1475af9153bf3d5234c33aa5c0ab415cbd254b711731cf8cffddac94b475f62d9fff2f9fe756b0fa30bb36d4343 SHA512 c00bb807e8fbc943e23a3721acf5b04320e7a58d658bca46bdf83a345b4c4d5729accae338505e134f01bc908adec9555fd94e8c87ef6f0367e6037215c06319
 DIST Flask-1.1.2.tar.gz 637516 BLAKE2B 90dffbb8faa48489d1c71ff2a064d41e97d2103c07532fd5b252dbe0b32e4babb815e31f0ceae201a66cead645b68149d13d4bb39a0df1b27b4002e613920493 SHA512 9feb6a9a8f34fadbea508d465f73c24b1d81b3f66243804dc3904d198c2fd78e2e1bef94df6a4940a7eec6b9b54abea06557a87de8b27b0a9497d18b3e071384
diff --git a/dev-python/flask/flask-0.12.2.ebuild b/dev-python/flask/flask-0.12.2.ebuild
deleted file mode 100644 (file)
index a836fc6..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
-       EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
-       inherit git-r3
-else
-       SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-       KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-       S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/click-2[${PYTHON_USEDEP}]
-       >=dev-python/blinker-1[${PYTHON_USEDEP}]
-       >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
-       >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # Prevent un-needed d'loading
-       sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
-       # DeprecationWarning: Flags not at the start of the expression
-       sed -e "s/r'\(.*\)\((?.*)\)'/r'\2\1'/" -i tests/test_basic.py || die
-       # issubclass(ModuleNotFoundError, ImportError)
-       sed -e 's/\(excinfo.type\) is \(ImportError\)/issubclass(\1, \2)/' \
-               -i tests/test_ext.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
-               py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use examples && dodoc -r examples
-       use doc && HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}