sys-kernel/raspberrypi-image: reuse sys-boot/raspberrypi-firmware distfile
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 15 Jul 2019 20:12:03 +0000 (21:12 +0100)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 15 Jul 2019 20:30:48 +0000 (21:30 +0100)
Before, if user installed both sys-kernel/raspberrypi-image and
sys-boot/raspberrypi-firmware, the same large distfile was downloaded
twice, and saved under different names. Also mirrors stored two copies
of this file by different names.

Now the file will be downloaded and stored only one time.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
sys-kernel/raspberrypi-image/Manifest
sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild
sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild

index 95d680339cfa20cd1722d398cbafb4666f4fbcb5..8c9481e5d0200fd04f48c2a6c03342186a6b0801 100644 (file)
@@ -1,2 +1,2 @@
+DIST raspberrypi-firmware-1.20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
 DIST raspberrypi-image-4.14.98_p20190215.tar.gz 123074917 BLAKE2B cefedb5c979db7dfd47938aad37a567d91d3ad78247c7a63f789362768ab7a39a1967ac116b4b0475e3b210ab11f6474706df042af85a622e8e7905c85ec7498 SHA512 082f26caf427222d838881e5f1e9fa0136765b3eaf74a84877fc33616fd07e49085db0889226c40c655039a9d41a10566510c7d752cfc48a67b4683616a51193
-DIST raspberrypi-image-4.19.57_p20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
index 6bd6d37a4aafa1ac9e2fda1d440d3b305ad700c6..ecd30c095746d76edcedf76cfc50248b1041dff1 100644 (file)
@@ -20,7 +20,7 @@ if [[ "${PV}" == 9999 ]]; then
 else
        [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
        MY_PV="1.$(ver_cut 5)"
-       SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
        S="${WORKDIR}/firmware-${MY_PV}"
        KEYWORDS="-* ~arm"
 fi
index 6bd6d37a4aafa1ac9e2fda1d440d3b305ad700c6..ecd30c095746d76edcedf76cfc50248b1041dff1 100644 (file)
@@ -20,7 +20,7 @@ if [[ "${PV}" == 9999 ]]; then
 else
        [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
        MY_PV="1.$(ver_cut 5)"
-       SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
        S="${WORKDIR}/firmware-${MY_PV}"
        KEYWORDS="-* ~arm"
 fi