dev-python/spyder-line-profiler: Plugin to run the line profiler within spyder
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Tue, 14 Jan 2020 11:47:27 +0000 (12:47 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 19 Feb 2020 07:02:43 +0000 (09:02 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/spyder-line-profiler/Manifest [new file with mode: 0644]
dev-python/spyder-line-profiler/metadata.xml [new file with mode: 0644]
dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
new file mode 100644 (file)
index 0000000..ce5d24d
--- /dev/null
@@ -0,0 +1 @@
+DIST spyder-line-profiler-0.2.0.tar.gz 70556 BLAKE2B 0f00c81b5598830a23df10ecbd23060e46218b39edfca80c06458da05a5b5f06ad644444f6876b5379a8cd2c4e590361c6061e22c0d70592fb8601e472a3b12c SHA512 302c5527834aae3ee940783170db08e436a311c4dee7bbbd51177c08ba8768af1c7b2d3a8af322d70dcfdb48f8e9ef86b0ccee4777ce4566e8579be98561eb94
diff --git a/dev-python/spyder-line-profiler/metadata.xml b/dev-python/spyder-line-profiler/metadata.xml
new file mode 100644 (file)
index 0000000..8fc1118
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..0845ccd
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/line_profiler[${PYTHON_USEDEP}]
+       >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+       dev-python/mock[${PYTHON_USEDEP}]
+       dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+       virtx pytest -vv spyder_line_profiler/widgets/tests
+}