dev-python/urllib3: Fix some of the tests
authorMichał Górny <mgorny@gentoo.org>
Sun, 22 Mar 2020 07:24:27 +0000 (08:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 22 Mar 2020 07:26:16 +0000 (08:26 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.25.8.ebuild

index ef0f1ab8a4a357a6cca7491e7f332a9b240df22b..e21205e47f94f521123fc26210d3dc76baae5407 100644 (file)
@@ -49,12 +49,9 @@ distutils_enable_sphinx docs \
        dev-python/mock
 
 python_prepare_all() {
-       # tests requiring a route to be present
-       sed -e 's:test_enhanced_timeout:_&:' \
-               -e 's:test_https_timeout:_&:' \
-               -i test/with_dummyserver/test_https.py || die
-       sed -e 's:test_https_proxy_.*timeout:_&:' \
-               -i test/with_dummyserver/test_proxy_poolmanager.py || die
+       # https://github.com/urllib3/urllib3/issues/1756
+       sed -e 's:10.255.255.1:240.0.0.0:' \
+               -i test/__init__.py || die
        # tests failing if 'localhost.' cannot be resolved
        sed -e 's:test_dotted_fqdn:_&:' \
                -i test/with_dummyserver/test_https.py || die
@@ -64,9 +61,7 @@ python_prepare_all() {
        # very flaky
        sed -e 's:test_client_no_intermediate:_&:' \
                -i test/with_dummyserver/test_https.py || die
-       sed -e 's:test_cross_host_redirect:_&:' \
-               -e 's:test_cross_protocol_redirect:_&:' \
-               -e 's:test_basic_ipv6_proxy:_&:' \
+       sed -e 's:test_basic_ipv6_proxy:_&:' \
                -i test/with_dummyserver/test_proxy_poolmanager.py || die
        sed -e 's:test_connection_closed_on_read_timeout_preload_false:_&:' \
                -i test/with_dummyserver/test_socketlevel.py || die