net-analyzer/sniffit: Version 0.4.0
authorJeroen Roovers <jer@gentoo.org>
Tue, 22 Oct 2019 20:55:33 +0000 (22:55 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 22 Oct 2019 23:50:59 +0000 (01:50 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/sniffit/Manifest
net-analyzer/sniffit/files/sniffit-0.4.4-tinfo.patch [new file with mode: 0644]
net-analyzer/sniffit/sniffit-0.4.0.ebuild [new file with mode: 0644]

index 71b24e9138ef3d80dbb1c9779042710acf8bc452..ff9839984826d67b962c1b31b2dfbfda1ecef87e 100644 (file)
@@ -1 +1,2 @@
+DIST sniffit-0.4.0.tar.gz 59640 BLAKE2B 0cb335e7fc308155d0b3b3163695745ba1b0b71f212341238074d80782d99b12ed3f4991eed766161bfb65aeffe8bbf5e8e71a987b431fd414ac34ab0be416ab SHA512 a31c39859ab308f3ad4bf2f32a61d0f419ed6ad5d1668efc79e996c4a99557e511fc0b36c21e30316cfa82217fb10fd16d4e3473f5f1fdd70cdeba959d643aab
 DIST sniffit.0.3.7.beta.tar.gz 212419 BLAKE2B 938f4eb775cfd0c604ec107573b8e4bba93fc60b40428ae3894b008fa4eaee3c9bf1ef29daf28caef4f22c4574faf2c6a8e3e8c32b7f84d643b8364ab31412ab SHA512 b32d1f17d589ee1d1afc7986640a2b9f451cdb26ee2d077db1eaec1bb77ed353bbbb6a79bd25f915b3a40b7a279f9fc7855706150ec3a24f8937a152ac91b8d1
diff --git a/net-analyzer/sniffit/files/sniffit-0.4.4-tinfo.patch b/net-analyzer/sniffit/files/sniffit-0.4.4-tinfo.patch
new file mode 100644 (file)
index 0000000..85e266f
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -12,7 +12,8 @@
+ AC_PROG_CC
+ # Checks for libraries.
+-AC_CHECK_LIB(ncurses, main, , [AC_MSG_ERROR([Couldn't find libncurses])])
++AC_CHECK_LIB(ncurses, initscr, , [AC_MSG_ERROR([Couldn't find libncurses])])
++AC_SEARCH_LIBS(keypad, tinfo, , [AC_MSG_ERROR([Couldn't find libncurses])])
+ AC_CHECK_LIB(pcap, pcap_open_live, , [AC_MSG_ERROR([Couldn't find libpcap])])
+ # Checks for header files.
diff --git a/net-analyzer/sniffit/sniffit-0.4.0.ebuild b/net-analyzer/sniffit/sniffit-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..3393767
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Interactive Packet Sniffer"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/sniffit"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+       net-libs/libpcap
+       >=sys-libs/ncurses-5.2
+"
+DEPEND="
+       ${RDEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.4.4-tinfo.patch
+)
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+       default
+       eautoreconf
+}