dev-python/fs: add python3_8 target
authorneeshy <neeshy@tfwno.gf>
Thu, 26 Mar 2020 21:49:33 +0000 (17:49 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sun, 19 Apr 2020 02:35:42 +0000 (22:35 -0400)
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf>
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/fs/fs-2.4.9-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/fs/fs-2.4.9-r1.ebuild b/dev-python/fs/fs-2.4.9-r1.ebuild
new file mode 100644 (file)
index 0000000..7bc6c8c
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+       https://pypi.org/project/fs/
+       https://docs.pyfilesystem.org
+       https://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+       $(python_gen_cond_dep '
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pyftpdlib[${PYTHON_USEDEP}]
+               dev-python/pysendfile[${PYTHON_USEDEP}]
+               dev-python/psutil[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
+               ' -3)
+)"
+
+python_test() {
+       # python2_7 tests require dev-python/typing which is
+       # now in stdlib so ignore tests. py2.7 is going away.
+       if python_is_python3; then
+               esetup.py test || die "tests failed"
+       fi
+}
+
+pkg_postinst() {
+       optfeature "S3 support" dev-python/boto
+       optfeature "SFTP support" dev-python/paramiko
+       optfeature "Browser support" dev-python/wxpython
+}