dev-python/icalendar: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 15:28:04 +0000 (16:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 15:28:04 +0000 (16:28 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/icalendar/Manifest
dev-python/icalendar/icalendar-3.11.7-r1.ebuild [deleted file]
dev-python/icalendar/icalendar-3.11.7.ebuild [deleted file]
dev-python/icalendar/icalendar-3.9.2.ebuild [deleted file]

index d0a2eb37787b507bb676da487301924e9997c6a1..5638437fac8ae8c29696782ac637ea5f1de95869 100644 (file)
@@ -1,3 +1 @@
-DIST icalendar-3.11.7.tar.gz 78330 BLAKE2B e6186f58903d835ac3357db959b6fef79aba34bb9b692128b6209b9c8139f7ed2eda81fd5cc54b6f3186d055e611f1489fcb61b1a10f914ee4c79ba8b31bf67a SHA512 445dc7b9c8c7ee2ad3345c5a4e4bca92633cdabae95f3cab63dacf549d48b7578242566d236cac8d5a9df4158387cadc0f09327e1b3e5038d223687365bec884
-DIST icalendar-3.9.2.tar.gz 66283 BLAKE2B 487a8fdf04f028de30003762860640b8983df026aa7a5ba0efe3a57ddd09c51bb406a5e58792203d3a0ee3d44186b0b6dcaa7194fefcfed85c3ab714129f6b4d SHA512 da50bba72f7a114263672ebd45cfcca5f7c2eca48538901f595b26ef18bb21a6290da4392c62cc27d1202083fcab7f5bfe6c9a463df38087de0ef764999f7eb1
 DIST icalendar-4.0.3.tar.gz 77899 BLAKE2B d4043914b85359a8309dd7c8acce55ec5921508319342f2ffb2e16017aa5aa164ef7fdd44aee7820a971516a3e157b5c8ee86732e669c8eac4b5c4bc1767e334 SHA512 2f0ac5a7f36c7d37047ba20bec3f2ca7df51a9e3ec3f29751c71cdd264c01f7e0abd6efc298dac5a7c87911cb4916e56bf77716d6ca05a2d090e26486e6a56be
diff --git a/dev-python/icalendar/icalendar-3.11.7-r1.ebuild b/dev-python/icalendar/icalendar-3.11.7-r1.ebuild
deleted file mode 100644 (file)
index accbaf9..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="collective-${PN}"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS="README.rst"
-
-RDEPEND="
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/python-dateutil[${PYTHON_USEDEP}]"
-
-DEPEND="
-       ${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/python-dateutil:0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # reset conf.py to not read version from an installed instance
-       sed -e "s:pkg_resources.get_distribution('icalendar').version:'3.9.0':" \
-               -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               pushd docs > /dev/null
-               emake text
-               popd > /dev/null
-               DOCS=( ${DOCS} docs/_build/text/*.txt )
-       fi
-}
-
-python_test() {
-       # From tox.ini
-       coverage run --source=src/icalendar --omit=*/tests/* --module \
-               pytest src/icalendar || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/icalendar/icalendar-3.11.7.ebuild b/dev-python/icalendar/icalendar-3.11.7.ebuild
deleted file mode 100644 (file)
index 118a0d3..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="collective-${PN}"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS="README.rst"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
-               dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/python-dateutil:0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # reset conf.py to not read version from an installed instance
-       sed -e "s:pkg_resources.get_distribution('icalendar').version:'3.9.0':" \
-               -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               pushd docs > /dev/null
-               emake text
-               popd > /dev/null
-               DOCS=( ${DOCS} docs/_build/text/*.txt )
-       fi
-}
-
-python_test() {
-       # From tox.ini
-       coverage run --source=src/icalendar --omit=*/tests/* --module \
-               pytest src/icalendar || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/icalendar/icalendar-3.9.2.ebuild b/dev-python/icalendar/icalendar-3.9.2.ebuild
deleted file mode 100644 (file)
index 048f445..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="collective-${PN}"
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS="README.rst"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
-               dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/python-dateutil:0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # reset conf.py to not read version from an installed instance
-       sed -e "s:pkg_resources.get_distribution('icalendar').version:'3.9.0':" \
-               -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               pushd docs > /dev/null
-               emake text
-               popd > /dev/null
-               DOCS=( ${DOCS} docs/_build/text/*.txt )
-       fi
-}
-
-python_test() {
-       # From tox.ini
-       coverage run --source=src/icalendar --omit=*/tests/* --module \
-               pytest src/icalendar || die "test failed under ${EPYTHON}"
-}