app-portage/gentoopm: Bump to 0.3.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 Nov 2019 17:13:24 +0000 (18:13 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 Nov 2019 17:15:42 +0000 (18:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/gentoopm/Manifest
app-portage/gentoopm/gentoopm-0.3.1.ebuild [new file with mode: 0644]

index 66a2e53b32e1a5fb0193c0d23789b63f28b50d7a..c958c5109877e229731c3f7b8929c46f9b952e8c 100644 (file)
@@ -1 +1,2 @@
 DIST gentoopm-0.3.0.tar.gz 37614 BLAKE2B c848c08677c4ac5ab0fdc1499045ae418048ec35d4ef925d1fe09ab4b68ec90e4f6843511efc29184883f3b3582bd3de519212bea1997736378b01bdc13ebd14 SHA512 e2a82f37b9a42688b6dd7023accdbf537780069deb6ca6ec6d9e159baf774af17e2a405c9eb40105b73b165f1c8c2ccde3ed685e04a61c9cd6665d1677da61d3
+DIST gentoopm-0.3.1.tar.gz 37897 BLAKE2B dd5499787bcc5c46ae3b559f3af4a5af5b4ca81a312e926149c587cac0391c51dbe61ac42d2bc19eb83cedc168486e9c30ddd6fbf4ae10ffd9719aefa2f54cd3 SHA512 e1a3a7929ae83d813dd0b03f0548f033e8e51b766aaddb653027398fb618819de6237e2ba1c0542defc9d62e71e8495aa10152cbc47a4e521f7cbaeda3ea4354
diff --git a/app-portage/gentoopm/gentoopm-0.3.1.ebuild b/app-portage/gentoopm/gentoopm-0.3.1.ebuild
new file mode 100644 (file)
index 0000000..dbdac94
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+       || (
+               >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+               >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+       esetup.py test
+}