net-libs/libktorrent: Fix build
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 17:30:12 +0000 (18:30 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 17:31:39 +0000 (18:31 +0100)
Broken all of a sudden by... who knows what.

Closes: https://bugs.gentoo.org/700090
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch [new file with mode: 0644]
net-libs/libktorrent/libktorrent-2.1.1.ebuild

diff --git a/net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch b/net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch
new file mode 100644 (file)
index 0000000..87d25e2
--- /dev/null
@@ -0,0 +1,25 @@
+From 1e8ce6e98d7ca0088624778964b9aed4696ce030 Mon Sep 17 00:00:00 2001
+From: Christoph Feck <cfeck@kde.org>
+Date: Thu, 14 Nov 2019 14:19:42 +0100
+Subject: Fix build with XFS
+
+BUG: 414050
+---
+ src/util/fileops.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/util/fileops.cpp b/src/util/fileops.cpp
+index c76b0e3..cfe4d5e 100644
+--- a/src/util/fileops.cpp
++++ b/src/util/fileops.cpp
+@@ -366,7 +366,7 @@ namespace bt
+       bool XfsPreallocate(const QString & path, Uint64 size)
+       {
+-              int fd = ::open(QFile::encodeName(path), O_RDWR | O_LARGEFILE);
++              int fd = ::open(QFile::encodeName(path).constData(), O_RDWR | O_LARGEFILE);
+               if (fd < 0)
+                       throw Error(i18n("Cannot open %1: %2",path,strerror(errno)));
+-- 
+cgit v1.1
index 34a552aa1dc06fcba60cd70eee1a67bfd97b9952..9399cfd161ba7afab7828fbd8c0801f44223a9eb 100644 (file)
@@ -36,7 +36,10 @@ RDEPEND="${COMMON_DEPEND}
        !dev-libs/botan[gmp(-)]
 "
 
-PATCHES=( "${FILESDIR}/${PN}-2.1-unused-link.patch" ) # git master
+PATCHES=(
+       "${FILESDIR}/${P}-fileops.patch" # bug 700090
+       "${FILESDIR}/${PN}-2.1-unused-link.patch" # git master
+)
 
 src_prepare() {
        kde5_src_prepare