net-dns/pdns: Revision bump, security bug #638566
authorSven Wegener <swegener@gentoo.org>
Mon, 27 Nov 2017 17:32:22 +0000 (17:32 +0000)
committerSven Wegener <swegener@gentoo.org>
Mon, 27 Nov 2017 17:36:52 +0000 (17:36 +0000)
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Signed-off-by: Sven Wegener <swegener@gentoo.org>
net-dns/pdns/Manifest
net-dns/pdns/files/CVE-2017-15091-4.0.4.patch [new file with mode: 0644]
net-dns/pdns/pdns-4.0.4-r1.ebuild [new file with mode: 0644]

index 8e03e0ac8e22887277740731a20605ea58f6374e..ef4e8b7dceda252d052685a0cbfff1f67883681a 100644 (file)
@@ -1,2 +1,2 @@
-DIST pdns-4.0.4.tar.bz2 1320327 SHA256 d974ab89de69477c7f581a3233bc731eacbb43d479291e472b2c531c83b6d763 SHA512 4ef4705cd990b03976775167c7c37850d45907e198549feda5f5701172e008e3f1f74a35a9bebdb24b63dec15ff63cb2cc9dfc8f92e4e1012e0539c5a88b845b WHIRLPOOL 5ac68a15155424d42fb4b84be1b34eb2e51498ae5193ae104215e4bb52a72845923f82dc6b112ce165444cdbfe3aaf01557d2f6ab42f6531dd525aee15ee1b19
-DIST pdns-4.1.0-rc3.tar.bz2 1112366 SHA256 889e2135ad4fa716afdd762a1c1551881e96f656f4434b0b1dcd57c63e87ffe2 SHA512 19485bf95a68cbe2ac4cc826b44c3a8670f66cedc2ab426c589a3f67d96f70bd6dd297bd95301c29cda10ff9a7e429fa702bdc7368ce08862140d7097013ea7f WHIRLPOOL 2e6e6b0a1b173aaa4ac61ac6b11204b30c2fde527476a218e13e62100d82a14b676075ce76e6b830e4c0e5d7f79c4421df9a4539ff9c0a9c110f9509c2d3a8a4
+DIST pdns-4.0.4.tar.bz2 1320327 BLAKE2B 5c11a0245408f8448b41ed4229718e6f7244e0c8f36b60b07c280f82c7dea0065cce93c3814b3a396666be8d3b012ad4eb646cf55f531d22ce325190e0fd6e22 SHA512 4ef4705cd990b03976775167c7c37850d45907e198549feda5f5701172e008e3f1f74a35a9bebdb24b63dec15ff63cb2cc9dfc8f92e4e1012e0539c5a88b845b
+DIST pdns-4.1.0-rc3.tar.bz2 1112366 BLAKE2B 8ac9d351ffee81a859b68bc66e989ce4c91804ab134ada3e090aed982df31191f5bfc83f7174873ab34b2a1b6be21f2c938874d94ea0e166b060453b746eec13 SHA512 19485bf95a68cbe2ac4cc826b44c3a8670f66cedc2ab426c589a3f67d96f70bd6dd297bd95301c29cda10ff9a7e429fa702bdc7368ce08862140d7097013ea7f
diff --git a/net-dns/pdns/files/CVE-2017-15091-4.0.4.patch b/net-dns/pdns/files/CVE-2017-15091-4.0.4.patch
new file mode 100644 (file)
index 0000000..a9506af
--- /dev/null
@@ -0,0 +1,30 @@
+diff -ru pdns-4.0.4.orig/pdns/ws-auth.cc pdns-4.0.4/pdns/ws-auth.cc
+--- pdns-4.0.4.orig/pdns/ws-auth.cc    2017-06-22 22:07:25.000000000 +0200
++++ pdns-4.0.4/pdns/ws-auth.cc 2017-11-02 18:07:20.986764858 +0100
+@@ -860,7 +860,7 @@
+ static void apiServerZoneAxfrRetrieve(HttpRequest* req, HttpResponse* resp) {
+   DNSName zonename = apiZoneIdToName(req->parameters["id"]);
+-  if(req->method != "PUT")
++  if(req->method != "PUT" || ::arg().mustDo("api-readonly"))
+     throw HttpMethodNotAllowedException();
+   UeberBackend B;
+@@ -879,7 +879,7 @@
+ static void apiServerZoneNotify(HttpRequest* req, HttpResponse* resp) {
+   DNSName zonename = apiZoneIdToName(req->parameters["id"]);
+-  if(req->method != "PUT")
++  if(req->method != "PUT" || ::arg().mustDo("api-readonly"))
+     throw HttpMethodNotAllowedException();
+   UeberBackend B;
+@@ -1191,7 +1191,7 @@
+ }
+ void apiServerCacheFlush(HttpRequest* req, HttpResponse* resp) {
+-  if(req->method != "PUT")
++  if(req->method != "PUT" || ::arg().mustDo("api-readonly"))
+     throw HttpMethodNotAllowedException();
+   DNSName canon = apiNameToDNSName(req->getvars["domain"]);
diff --git a/net-dns/pdns/pdns-4.0.4-r1.ebuild b/net-dns/pdns/pdns-4.0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..9fa2350
--- /dev/null
@@ -0,0 +1,157 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib user toolchain-funcs versionator
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sqlite systemd tools tinydns test"
+
+REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
+
+RDEPEND="
+       libressl? ( dev-libs/libressl:= )
+       !libressl? ( dev-libs/openssl:= )
+       >=dev-libs/boost-1.35:=
+       botan? ( =dev-libs/botan-1.10*[threads] )
+       lua? ( dev-lang/lua:= )
+       luajit? ( dev-lang/luajit:= )
+       mysql? ( virtual/mysql )
+       postgres? ( dev-db/postgresql:= )
+       ldap? ( >=net-nds/openldap-2.0.27-r4 )
+       sqlite? ( dev-db/sqlite:3 )
+       opendbx? ( dev-db/opendbx )
+       geoip? ( >=dev-cpp/yaml-cpp-0.5.1 dev-libs/geoip )
+       tinydns? ( >=dev-db/tinycdb-0.77 )
+       protobuf? ( dev-libs/protobuf )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}"/${P/_/-}
+
+PATCHES=(
+       "${FILESDIR}"/CVE-2017-15091-4.0.4.patch
+)
+
+src_configure() {
+       local dynmodules="pipe bind" # the default backends, always enabled
+
+       #use db2 && dynmodules+=" db2"
+       use ldap && dynmodules+=" ldap"
+       use lua && dynmodules+=" lua"
+       use mydns && dynmodules+=" mydns"
+       use mysql && dynmodules+=" gmysql"
+       use opendbx && dynmodules+=" opendbx"
+       #use oracle && dynmodules+=" goracle oracle"
+       use postgres && dynmodules+=" gpgsql"
+       use remote && dynmodules+=" remote"
+       use sqlite && dynmodules+=" gsqlite3"
+       use tinydns && dynmodules+=" tinydns"
+       use geoip && dynmodules+=" geoip"
+       #use xdb && dynmodules+=" xdb"
+
+       econf \
+               --disable-static \
+               --sysconfdir=/etc/powerdns \
+               --libdir=/usr/$(get_libdir)/powerdns \
+               --with-modules= \
+               --with-dynmodules="${dynmodules}" \
+               --with-pgsql-includes=/usr/include \
+               --with-pgsql-lib=/usr/$(get_libdir) \
+               --with-mysql-lib=/usr/$(get_libdir) \
+               $(use_enable botan botan1.10) \
+               $(use_enable debug verbose-logging) \
+               $(use_enable test unit-tests) \
+               $(use_enable tools) \
+               $(use_enable systemd) \
+               $(use_with lua) \
+               $(use_with luajit) \
+               $(use_with protobuf) \
+               ${myconf}
+}
+
+src_compile() {
+       default
+       use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+       default
+
+       mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+       fperms 0700 /etc/powerdns
+       fperms 0600 /etc/powerdns/pdns.conf
+
+       # set defaults: setuid=pdns, setgid=pdns
+       sed -i \
+               -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+               "${D}"/etc/powerdns/pdns.conf
+
+       newinitd "${FILESDIR}"/pdns-r1 pdns
+
+       keepdir /var/empty
+
+       use doc && dohtml -r codedocs/html/.
+
+       # Install development headers
+       insinto /usr/include/pdns
+       doins pdns/*.hh
+       insinto /usr/include/pdns/backends/gsql
+       doins pdns/backends/gsql/*.hh
+
+       if use ldap ; then
+               insinto /etc/openldap/schema
+               doins "${FILESDIR}"/dnsdomain2.schema
+       fi
+
+       prune_libtool_files --all
+}
+
+pkg_preinst() {
+       enewgroup pdns
+       enewuser pdns -1 -1 /var/empty pdns
+}
+
+pkg_postinst() {
+       elog "PowerDNS provides multiple instances support. You can create more instances"
+       elog "by symlinking the pdns init script to another name."
+       elog
+       elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+       elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+       if use ldap ; then
+               ewarn "The official LDAP backend module is only compile-tested by upstream."
+               ewarn "Try net-dns/pdns-ldap-backend if you have problems with it."
+       fi
+
+       local old
+       for old in ${REPLACING_VERSIONS}; do
+               version_compare ${old} 3.2
+               [[ $? -eq 1 ]] || continue
+
+               ewarn "To fix a security bug (bug #458018) had the following"
+               ewarn "files/directories the world-readable bit removed (if set):"
+               ewarn "  ${EPREFIX}/etc/powerdns"
+               ewarn "  ${EPREFIX}/etc/powerdns/pdns.conf"
+               ewarn "Check if this is correct for your setup"
+               ewarn "This is a one-time change and will not happen on subsequent updates."
+               chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+               break
+       done
+}