Version bump.
authorLars Weiler <pylon@gentoo.org>
Fri, 19 Jan 2007 19:11:46 +0000 (19:11 +0000)
committerLars Weiler <pylon@gentoo.org>
Fri, 19 Jan 2007 19:11:46 +0000 (19:11 +0000)
Package-Manager: portage-2.1.2_rc4-r9

games-simulation/openttd/ChangeLog
games-simulation/openttd/files/digest-openttd-0.5.0_rc4 [new file with mode: 0644]
games-simulation/openttd/openttd-0.5.0_rc4.ebuild [new file with mode: 0644]

index 1427a1ec59979849117c39d05fee46536635f296..6f1d4146c658bf442fce788bae94d96f2ff6733e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for games-simulation/openttd
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.33 2007/01/14 01:23:41 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.34 2007/01/19 19:11:46 pylon Exp $
+
+*openttd-0.5.0_rc4 (19 Jan 2007)
+
+  19 Jan 2007; Lars Weiler <pylon@gentoo.org> -openttd-0.5.0_rc2.ebuild,
+  +openttd-0.5.0_rc4.ebuild:
+  Version bump.
 
 *openttd-0.5.0_rc3 (14 Jan 2007)
 
diff --git a/games-simulation/openttd/files/digest-openttd-0.5.0_rc4 b/games-simulation/openttd/files/digest-openttd-0.5.0_rc4
new file mode 100644 (file)
index 0000000..922844b
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 34e8cb13ce1d4e6b5b24887c628c1ac8 openttd-0.4.8-scenarios.tar.bz2 5000799
+RMD160 a6c2fa9f81e4e4628adb9c3932dec46ab4789777 openttd-0.4.8-scenarios.tar.bz2 5000799
+SHA256 61788035bd78a3c0e393d5992432c37e0b6036d19a960543f26d43a46e39e6ca openttd-0.4.8-scenarios.tar.bz2 5000799
+MD5 3e4453ae98a256af758f4a2a9e2056ea openttd-0.5.0-RC4-source.tar.bz2 2938287
+RMD160 03daefcc8e8ff4b9f0292ea7f6352c24417d1c47 openttd-0.5.0-RC4-source.tar.bz2 2938287
+SHA256 527fb8c57eb5ca03a0c683c44945bc062d9c27e64ce49b5da3eb983d254b03ca openttd-0.5.0-RC4-source.tar.bz2 2938287
diff --git a/games-simulation/openttd/openttd-0.5.0_rc4.ebuild b/games-simulation/openttd/openttd-0.5.0_rc4.ebuild
new file mode 100644 (file)
index 0000000..8f764c8
--- /dev/null
@@ -0,0 +1,184 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.0_rc4.ebuild,v 1.1 2007/01/19 19:11:46 pylon Exp $
+
+inherit eutils games
+
+MY_P=${P/_rc/-RC}
+
+SCENARIOS_A="${PN}-0.4.8-scenarios.tar.bz2"
+SCENARIOS_DIR="${PN}-0.4.8-RC1-scenarios"
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SB="mirror://sourceforge/openttd"
+SRC_URI="${SB}/${MY_P}-source.tar.bz2
+               scenarios? ( ${SB}/${SCENARIOS_A} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa debug dedicated png scenarios timidity unicode zlib"
+
+DEPEND="!dedicated? ( media-libs/libsdl )
+       png? ( media-libs/libpng )
+       scenarios? ( app-arch/unzip )
+       zlib? ( sys-libs/zlib )
+       unicode? ( virtual/libiconv )"
+RDEPEND="${DEPEND}
+       !dedicated? (
+               timidity? ( media-sound/timidity++ )
+               !timidity? ( alsa? ( media-sound/alsa-utils ) )
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${MY_P}-source.tar.bz2
+       if use scenarios; then
+               cd ${S}/scenario/
+               unpack ${SCENARIOS_A}
+       fi
+       cd ${S}
+       # Don't pre-strip binaries (bug #137822)
+       sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
+       # Don't install into prefixed DATA_DIR
+       sed -i -e \
+               's#DATA_DIR_PREFIXED:=$(PREFIX)/$(DATA_DIR)#DATA_DIR_PREFIXED:=$(DATA_DIR)#' \
+               Makefile || die "sed failed"
+}
+
+src_compile() {
+       local myopts=""
+       use debug && myopts="${myopts} DEBUG=1"
+       use dedicated && myopts="${myopts} DEDICATED=1"
+       use png && myopts="${myopts} WITH_PNG=1"
+       use zlib && myopts="${myopts} WITH_ZLIB=1"
+       use unicode && myopts="${myopts} WITH_ICONV=1"
+       if ! use dedicated; then
+               myopts="${myopts} WITH_SDL=1"
+               if ! use timidity; then
+                       use alsa && myopts="${myopts} MIDI=/usr/bin/aplaymidi"
+               fi
+       fi
+
+       # parallel build not supported
+       emake -j1 \
+               MANUAL_CONFIG=1 \
+               UNIX=1 \
+               WITH_NETWORK=1 \
+               INSTALL=1 \
+               RELEASE=${PV} \
+               USE_HOMEDIR=1 \
+               DEST_DIR=${D} \
+               PERSONAL_DIR=.openttd \
+               PREFIX=${GAMES_PREFIX} \
+               DATA_DIR=${GAMES_DATADIR}/${PN} \
+               CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
+               ${myopts} \
+               || die "emake failed"
+}
+
+src_install() {
+       dogamesbin openttd || die "dogamesbin failed"
+
+       insinto "${GAMES_DATADIR}/${PN}/data"
+       doins data/* || die "doins failed (data)"
+
+       insinto "${GAMES_DATADIR}/${PN}/lang"
+       doins lang/*.lng || die "doins failed (lang)"
+
+       if use scenarios; then
+               insinto "${GAMES_DATADIR}/${PN}/scenario"
+               doins scenario/${SCENARIOS_DIR}/* || die "doins failed (scenario)"
+       fi
+
+       insinto "${GAMES_DATADIR}/${PN}/scripts"
+       doins scripts/*.example || die "doins failed (scripts)"
+
+       for i in {16,32,48,64,128}; do
+               insinto /usr/share/icons/hicolor/${i}x${i}/apps
+               newins media/openttd.${i}.png openttd.png
+       done
+
+       if ! use dedicated; then
+               if use timidity || use alsa; then
+                       make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
+               else
+                       make_desktop_entry openttd "OpenTTD" openttd
+               fi
+       else
+               newinitd "${FILESDIR}"/openttd.initd openttd
+       fi
+
+       dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt docs/console.txt docs/multiplayer.txt
+       dohtml -a html,gif,png,svg docs/*
+       newdoc scripts/readme.txt readme_scripts.txt
+       doman docs/openttd.6
+       prepgamesdirs
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+
+       echo
+       einfo "In order to play, you must copy the following 6 files from "
+       einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+       echo
+       einfo "From the WINDOWS version you need: "
+       einfo "  sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+       einfo "OR from the DOS version you need: "
+       einfo "  SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+       echo
+       einfo "File names are case sensitive so make sure they are "
+       einfo "correct for whichever version you have."
+       echo
+
+       if ! use scenarios; then
+               einfo "Scenarios are now included in a seperate package. To "
+               einfo "install them as well please remerge with the "
+               einfo "\"scenarios\" USE flag."
+               echo
+       else
+               einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
+               einfo "you will have to symlink them to ~/.openttd/scenario in order"
+               einfo "to use them."
+               einfo "Example:"
+               einfo "  mkdir -p ~/.openttd/scenario"
+               einfo "  ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+               echo
+       fi
+
+       if use dedicated; then
+               einfo "You have chosen the dedicated USE flag which builds a "
+               einfo "version of OpenTTD to be used as a game server which "
+               einfo "does not require SDL. You will not be able to play the "
+               einfo "game, but if you don't pass this flag you can still use "
+               einfo "it as a server in the same way, but SDL will be required."
+               echo
+               ewarn "Warning: The init script will kill all running openttd"
+               ewarn "processes when run, including any running client sessions!"
+               echo
+       else
+               if use timidity || use alsa; then
+                       einfo "If you want music, you must copy the gm/ directory"
+                       einfo "to ${GAMES_DATADIR}/${PN}/"
+                       einfo "You can enable MIDI by running:"
+                       einfo "  openttd -m extmidi"
+                       echo
+                       if use timidity; then
+                               einfo "You also need soundfonts for timidity, if you don't"
+                               einfo "know what that is, do:"
+                               echo
+                               einfo "emerge media-sound/timidity-eawpatches"
+                       else
+                               einfo "You have emerged with 'aplaymidi' for playing MIDI."
+                               einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+                               einfo "Available ports can be listed by using 'aplaymidi -l'."
+                       fi
+               else
+                       einfo "timidity and/or alsa not in USE so music will not be played during the game."
+               fi
+               echo
+       fi
+}