net-vpn/openvpn: 2.4.9 bump
authorWilliam Hubbs <williamh@gentoo.org>
Wed, 22 Apr 2020 23:36:53 +0000 (18:36 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Wed, 22 Apr 2020 23:38:44 +0000 (18:38 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
net-vpn/openvpn/Manifest
net-vpn/openvpn/openvpn-2.4.9.ebuild [new file with mode: 0644]

index 6d128f74611d2aeb55cabe7bc2695074af14e530..2ba62782fbd5360103829be4b6b7152df30ef506 100644 (file)
@@ -2,3 +2,4 @@ DIST mock_msg.h 1356 BLAKE2B da7585cfeee89c0a4d3aa6326de6e2324804ed2a57a0e8bf7c2
 DIST openvpn-2.4.6.tar.gz 1431971 BLAKE2B 1ab0746a845fc56bf738c1730cc187c27f61d5bb763df149640978f0bf87450a01e3e40372265440f1aae4e1c58b6d9a1ee1f2aade970d19fd8e8813e0b487a7 SHA512 cdd70bfd03177bc6cb70d0d614e40389df00816b7097740b4cda9d7bee094d1463fdb5afeaf604c52c7b3167d1edb098a2e095e131a8b9fed0ed8b29da90cbe8
 DIST openvpn-2.4.7.tar.gz 998094 BLAKE2B 90f91d74279a547b49704cd14d9ac3dde26c522cd77eb851ea603addb1b220eda9be4de6cf5d74fe7717f34b3ff5fc802ca977a1402c5ed75616139d449fceb0 SHA512 ba9bc08c02fad85ba05c27488b0bfcb3540ba9c625c42334e24cb1d5e253b91c518c02641d755e03b8747ae8c2ebd340c55d51f7aedbbf2550ee4e4b79823c9c
 DIST openvpn-2.4.8.tar.gz 997417 BLAKE2B 1c56d25c125039b9f0723d8f498c9cc7233c9da940d961a430c82a3c41448c0c4fc64255adad59513d4e39b8e778cf58ced965e1501793c47bc73d211c339e4e SHA512 6a5f6f6a5cccc5011019e64ed452ad395942b751589893bd6fd3159b20577d734f2fe35d2f51f30303adee3a21e67da6d25369ea4421288ba7c2e09445e2c001
+DIST openvpn-2.4.9.tar.gz 1000602 BLAKE2B 4a10ec76d1a816f9184dd33e4384623e011a1af40ea38ad56cc06f70ab2c911b6fd92cf8ffcd2ec3ab4179fef87feb187fc9df61c5bea92b1c69ee4113093866 SHA512 7683dfb93592968459f080a07ea750992b7444708cdb1a5aafc0118ab8528fc488f2b9fbd7d042e57ad1811303208875237ae9decf0bb4977c45cd30da53751b
diff --git a/net-vpn/openvpn/openvpn-2.4.9.ebuild b/net-vpn/openvpn/openvpn-2.4.9.ebuild
new file mode 100644 (file)
index 0000000..0310e51
--- /dev/null
@@ -0,0 +1,145 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd linux-info
+
+DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
+SRC_URI="https://github.com/OpenVPN/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://openvpn.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="pkcs11? ( ssl )
+       !plugins? ( !pam !down-root )
+       inotify? ( plugins )
+"
+
+CDEPEND="
+       kernel_linux? (
+               iproute2? ( sys-apps/iproute2[-minimal] )
+               !iproute2? ( >=sys-apps/net-tools-1.60_p20160215155418 )
+       )
+       pam? ( sys-libs/pam )
+       ssl? (
+               !mbedtls? (
+                       !libressl? ( >=dev-libs/openssl-0.9.8:0= )
+                       libressl? ( dev-libs/libressl:0= )
+               )
+               mbedtls? ( net-libs/mbedtls:= )
+       )
+       lz4? ( app-arch/lz4 )
+       lzo? ( >=dev-libs/lzo-1.07 )
+       pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
+       systemd? ( sys-apps/systemd )
+"
+DEPEND="${CDEPEND}
+       test? ( dev-util/cmocka )
+"
+RDEPEND="${CDEPEND}
+       acct-group/openvpn
+       acct-user/openvpn
+       selinux? ( sec-policy/selinux-openvpn )
+"
+
+CONFIG_CHECK="~TUN"
+
+pkg_setup() {
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
+       TMPFILES_DIR="/usr/lib/tmpfiles.d" \
+       IFCONFIG=/bin/ifconfig \
+       ROUTE=/bin/route \
+       econf \
+               $(use_enable inotify async-push) \
+               $(use_enable ssl crypto) \
+               $(use_with ssl crypto-library $(usex mbedtls mbedtls openssl)) \
+               $(use_enable lz4) \
+               $(use_enable lzo) \
+               $(use_enable pkcs11) \
+               $(use_enable plugins) \
+               $(use_enable iproute2) \
+               $(use_enable pam plugin-auth-pam) \
+               $(use_enable down-root plugin-down-root) \
+               $(use_enable systemd)
+}
+
+src_test() {
+       make check || die "top-level tests failed"
+       pushd tests/unit_tests > /dev/null || die
+       make check || die "unit tests failed"
+       popd > /dev/null || die
+}
+
+src_install() {
+       default
+       find "${ED}/usr" -name '*.la' -delete
+       # install documentation
+       dodoc AUTHORS ChangeLog PORTS README README.IPv6
+
+       # Install some helper scripts
+       keepdir /etc/openvpn
+       exeinto /etc/openvpn
+       doexe "${FILESDIR}/up.sh"
+       doexe "${FILESDIR}/down.sh"
+
+       # Install the init script and config file
+       newinitd "${FILESDIR}/${PN}-2.1.init" openvpn
+       newconfd "${FILESDIR}/${PN}-2.1.conf" openvpn
+
+       # install examples, controlled by the respective useflag
+       if use examples ; then
+               # dodoc does not supportly support directory traversal, #15193
+               docinto /usr/share/doc/${PF}/examples
+               dodoc -r sample contrib
+       fi
+}
+
+pkg_postinst() {
+       if use x64-macos; then
+               elog "You might want to install tuntaposx for TAP interface support:"
+               elog "http://tuntaposx.sourceforge.net"
+       fi
+
+       elog "The openvpn init script expects to find the configuration file"
+       elog "openvpn.conf in /etc/openvpn along with any extra files it may need."
+       elog ""
+       elog "To create more VPNs, simply create a new .conf file for it and"
+       elog "then create a symlink to the openvpn init script from a link called"
+       elog "openvpn.newconfname - like so"
+       elog "   cd /etc/openvpn"
+       elog "   ${EDITOR##*/} foo.conf"
+       elog "   cd /etc/init.d"
+       elog "   ln -s openvpn openvpn.foo"
+       elog ""
+       elog "You can then treat openvpn.foo as any other service, so you can"
+       elog "stop one vpn and start another if you need to."
+
+       if grep -Eq "^[ \t]*(up|down)[ \t].*" "${ROOT}/etc/openvpn"/*.conf 2>/dev/null ; then
+               ewarn ""
+               ewarn "WARNING: If you use the remote keyword then you are deemed to be"
+               ewarn "a client by our init script and as such we force up,down scripts."
+               ewarn "These scripts call /etc/openvpn/\$SVCNAME-{up,down}.sh where you"
+               ewarn "can move your scripts to."
+       fi
+
+       if use plugins ; then
+               einfo ""
+               einfo "plugins have been installed into /usr/$(get_libdir)/${PN}/plugins"
+       fi
+}