dev-python/smmap: Bump to 3.0.1, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 20:18:25 +0000 (21:18 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 21:17:49 +0000 (22:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/smmap/Manifest
dev-python/smmap/smmap-3.0.1.ebuild [new file with mode: 0644]

index d47725fd4e2d32d3773c4b6aad42281a0f9245be..f850272be51b281d2592be42f9e5eb07d8d4246d 100644 (file)
@@ -1 +1,2 @@
 DIST smmap-0.9.0.tar.gz 22082 BLAKE2B a0c7e5957a4ea829a3f7855ac5d05660ac2bc6ed8e58a50b805a4c07899ce5022d5bbc0329604dd2296dace3e6e6165cb108be8014c4c834629f830af14a4562 SHA512 704e1c67b1f3e1303578cc26d4af8296a11b5f5013e8e8d933d3096e588911b801ddfb162d0e35a49c00256032824386d77e4f38d58704cd57baf21586b40e03
+DIST smmap-3.0.1.tar.gz 23659 BLAKE2B 19a9425d039141acc00ddc939dab97390d6f619b2d9049ee9c8e483718da1dc06fcd937c6736ecf91a4d55af2b5ff7612de93690334fbfa9bc3904a597e517bd SHA512 36594896212d218c5bc9e27ae16f692643d2236ff13a55461a35d0d688fcf40f6082caa003f178d7bd8b999d4571de269d708f299413dbef46b58ae2074bfc9a
diff --git a/dev-python/smmap/smmap-3.0.1.ebuild b/dev-python/smmap/smmap-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..73277c5
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+       https://pypi.org/project/smmap/
+       https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest