app-misc/ledit: Replace STRIP_MASK with RESTRICT=strip
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Apr 2019 08:39:47 +0000 (10:39 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:17:03 +0000 (22:17 +0200)
Closes: https://bugs.gentoo.org/651426
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/11676
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-misc/ledit/ledit-2.03.ebuild

index caec36f62406ab68cbe820af1675a155c4cb3aba..4810b328c9a0c18a36533725a28b2388960a0c82 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -18,15 +18,12 @@ RDEPEND="${DEPEND}"
 SLOT="0"
 LICENSE="BSD"
 KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+RESTRICT="!ocamlopt? ( strip )"
 
 src_compile() {
        emake -j1 all
        if use ocamlopt; then
                emake -j1 ledit.opt
-       else
-               # If using bytecode we dont want to strip the binary as it would remove the
-               # bytecode and only leave ocamlrun...
-               export STRIP_MASK="*/bin/*"
        fi
 }