Version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 2 Feb 2007 13:46:05 +0000 (13:46 +0000)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 2 Feb 2007 13:46:05 +0000 (13:46 +0000)
Package-Manager: portage-2.1.2-r5

dev-libs/libgcrypt/ChangeLog
dev-libs/libgcrypt/files/digest-libgcrypt-1.2.4 [new file with mode: 0644]
dev-libs/libgcrypt/libgcrypt-1.2.4.ebuild [new file with mode: 0644]

index 0d768b80c33cb578da34cdbde430a472af0b948e..a18612d1f468a1554412642ec93cbbcaa83320e0 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/libgcrypt
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.87 2007/01/12 20:48:36 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.88 2007/02/02 13:46:05 alonbl Exp $
+
+*libgcrypt-1.2.4 (02 Feb 2007)
+
+  02 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org> +libgcrypt-1.2.4.ebuild:
+  Version bump
 
   12 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> libgcrypt-1.2.3-r1.ebuild:
   Remove WANT_AUTO*
diff --git a/dev-libs/libgcrypt/files/digest-libgcrypt-1.2.4 b/dev-libs/libgcrypt/files/digest-libgcrypt-1.2.4
new file mode 100644 (file)
index 0000000..1ef2ae6
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 5cf59068f593221bf94dc962630bd84d libgcrypt-1.2.1-patches.tar.gz 2631
+RMD160 314b601285d48bd57b89dca1e20779256c7ed3e4 libgcrypt-1.2.1-patches.tar.gz 2631
+SHA256 f1900ed55883dc8619fd4e5eabe16cb463873884683bbeb9c9a6d9dc53a18ed6 libgcrypt-1.2.1-patches.tar.gz 2631
+MD5 180b668f2b114121d28df15cfc22ac8f libgcrypt-1.2.4-idea.diff.bz2 2924
+RMD160 199cfb4224b6cebc940f4cfb876deb700e9dc044 libgcrypt-1.2.4-idea.diff.bz2 2924
+SHA256 a3d5db94f50492c27de5b4ce64ae7974c5293012dea730bfb46df948954a6aa9 libgcrypt-1.2.4-idea.diff.bz2 2924
+MD5 be20ee47778ff90703afd58c090f07b9 libgcrypt-1.2.4.tar.gz 1013625
+RMD160 6a5ba284efe48c6963e21d8558a69096aea03d84 libgcrypt-1.2.4.tar.gz 1013625
+SHA256 cf3c3f313ebeb9165d80439beaeb7f621b73856a2159e4b84c70f32b455fd9ec libgcrypt-1.2.4.tar.gz 1013625
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.4.ebuild
new file mode 100644 (file)
index 0000000..c84c1d1
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.4.ebuild,v 1.1 2007/02/02 13:46:05 alonbl Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.gz
+       mirror://gentoo/${PN}-1.2.1-patches.tar.gz
+       !bindist? ( idea? ( mirror://gentoo/${P}-idea.diff.bz2 ) )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls bindist idea"
+
+RDEPEND="nls? ( virtual/libintl )
+       dev-libs/libgpg-error"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )"
+
+src_unpack() {
+       unpack ${A}
+       epunt_cxx
+
+       # fix for miss detection of 32 bit ppc
+       cd "${S}"
+       epatch "${WORKDIR}/${PN}-1.2.1-ppc64-fix.patch"
+       epatch "${FILESDIR}/${PN}-1.2.3-strict-aliasing.patch"
+
+       if use idea; then
+               if use bindist; then
+                       einfo "Skipping IDEA support to comply with binary distribution (bug #148907)."
+               else
+                       ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
+                       epatch "${WORKDIR}/${P}-idea.diff"
+               fi
+       fi
+
+       eautoreconf
+}
+
+src_compile() {
+       local myconf
+
+       use ppc64 && myconf="${myconf} --disable-asm"
+
+       econf $(use_enable nls) --disable-dependency-tracking --with-pic \
+               --enable-noexecstack ${myconf} || die
+       emake || die
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+
+       # backwards compat symlinks
+       dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
+}
+
+pkg_postinst() {
+       if use !bindist && use idea; then
+               einfo "-----------------------------------------------------------------------------------"
+               einfo "IDEA"
+               ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
+               ewarn "is distributed under the GPL in countries where it is permitted to do so"
+               ewarn "by law."
+               einfo
+               einfo "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
+               einfo
+               ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
+               ewarn "to use it at no cost for 'non revenue generating data transfer between private"
+               ewarn "individuals'."
+               einfo
+               einfo "Countries where the patent applies are listed here"
+               einfo "http://www.mediacrypt.com/_contents/10_idea/101030_ea_pi.asp"
+               einfo
+               einfo "Further information and other licenses are availble from http://www.mediacrypt.com/"
+               einfo "-----------------------------------------------------------------------------------"
+       fi
+}