dev-php/ZendFramework: add src_unpack to move unpacked archive Bug 558982
authorBrian Evans <grknight@gentoo.org>
Mon, 31 Aug 2015 23:54:02 +0000 (19:54 -0400)
committerBrian Evans <grknight@gentoo.org>
Mon, 31 Aug 2015 23:54:02 +0000 (19:54 -0400)
The minimal USE has a separate archive which needs to be moved to S

Package-Manager: portage-2.2.20.1

dev-php/ZendFramework/ZendFramework-1.12.9.ebuild

index d4b445b6034430f767f715cc04b2112d3a6e9a4a..f26758c27795d7e2239e3765e212227f962a0427 100644 (file)
@@ -24,9 +24,15 @@ IUSE="cli doc examples minimal"
 DEPEND="cli? ( dev-lang/php:*[simplexml,tokenizer] )"
 RDEPEND="${DEPEND}"
 
+src_unpack() {
+       default
+       if use minimal ; then
+               mv "${WORKDIR}/${P}-minimal" "${S}" || die
+       fi
+}
+
 src_prepare() {
        if use minimal ; then
-               S="${WORKDIR}/${P}-minimal"
                if use doc ; then
                        mv "${WORKDIR}/${P}/documentation" "${S}"
                fi