net-misc/socat: Fix CFLAGS=-fno-common USE=tcpd
authorJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 11:04:03 +0000 (12:04 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 11:05:14 +0000 (12:05 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/socat/files/socat-1.7.3.4-fno-common.patch [new file with mode: 0644]
net-misc/socat/socat-1.7.3.4.ebuild
net-misc/socat/socat-2.0.0_beta9.ebuild
net-misc/socat/socat-9999.ebuild

diff --git a/net-misc/socat/files/socat-1.7.3.4-fno-common.patch b/net-misc/socat/files/socat-1.7.3.4-fno-common.patch
new file mode 100644 (file)
index 0000000..a7dcf71
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/filan.c
++++ b/filan.c
+@@ -30,7 +30,9 @@
+ /* dirty workaround so we dont get an error on AIX when being linked with
+    libwrap */
++#if _AIX
+ int allow_severity, deny_severity;
++#endif
+ /* global variables for configuring filan */
+ bool filan_followsymlinks;
+--- a/procan.c
++++ b/procan.c
+@@ -21,7 +21,9 @@
+ /* dirty workaround so we dont get an error on AIX when getting linked with
+    libwrap */
++#if _AIX
+ int allow_severity, deny_severity;
++#endif
+ int procan(FILE *outfile) {
index 5c208be530b65502658fd2ff80b8333235176fb1..d964ea01444cac8a748a6fcccafd0eb6ad96d802 100644 (file)
@@ -33,6 +33,9 @@ RESTRICT="
 DOCS=(
        BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
 )
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
+)
 
 pkg_setup() {
        # bug #587740
index f8881af9ed2107b25201ff98178ede9136004611..d5d7fe265575bf4a7749531043f9438b82abbab2 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-
+EAPI=7
 inherit autotools flag-o-matic toolchain-funcs
 
 DESCRIPTION="Multipurpose relay (SOcket CAT)"
@@ -36,6 +35,7 @@ DOCS=(
 PATCHES=(
        "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
        "${FILESDIR}"/${PN}-1.7.3.1-stddef_h.patch
+       "${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
        "${FILESDIR}"/${PN}-2.0.0_beta9-libressl.patch
 )
 
index dfc7752ca39645957d4c670778cb3466514f01c2..2c12dbc3dc4fc6db32dcf8f8e3e326e3c985fe1b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -34,6 +34,7 @@ DOCS=(
 )
 
 PATCHES=(
+       "${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
        "${FILESDIR}"/${PN}-9999-stddef_h.patch
 )