dev-tcltk/tclxml: bump to 2.3.7
authorAlfredo Tupone <tupone@gentoo.org>
Sat, 9 May 2020 08:43:13 +0000 (10:43 +0200)
committerAlfredo Tupone <tupone@gentoo.org>
Sat, 9 May 2020 08:43:13 +0000 (10:43 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/tclxml/Manifest
dev-tcltk/tclxml/tclxml-3.2.7.ebuild [new file with mode: 0644]

index 7e67c72b1b53f030b3ad274322852ebe3dea229e..929aa2bbe6733804f9a6887dbe6df1b8c585646e 100644 (file)
@@ -1 +1,2 @@
+DIST tclxml-3.2.7.tar.gz 313751 BLAKE2B 43983d2d6c2f339fa320c4748f889db49fbe9cfff15219e898fdfe5a9a7d6526a2b40b7697fdca6f5272bdfb52cbe68af53ced711ad5d476dc2c5e31898c00ba SHA512 23cb17466f777538088998fa4cce55531708bba517d45cb8b4281401779c418f8532376e4aefcf4bb5f3674ee5bab2e0db25ab2a69c153d3e5820c509edf12ae
 DIST tclxml-3.2.tar.gz 757594 BLAKE2B 6ddadb6add6ccba0db55e704ddffafe1c0f22740d27a5c49bf9c8fd00e1592aed46fd1cef49155101ac1544de8559f0d808731c598cf2189ff84a681bbf870e6 SHA512 5e7d45063c1a311d49ecc42f664bf7d88862fc19a46b64f52d038e2adfcc5b6964ae74d61b40bcf8eb4e1440f849339095fd8712bd39f0cb57e279acea58a3da
diff --git a/dev-tcltk/tclxml/tclxml-3.2.7.ebuild b/dev-tcltk/tclxml/tclxml-3.2.7.ebuild
new file mode 100644 (file)
index 0000000..af6d475
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib
+
+DESCRIPTION="Pure Tcl implementation of an XML parser"
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="https://github.com/wjoye/${PN}/archive/v${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+IUSE="debug threads"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+       >=dev-lang/tcl-8.2:0
+       >=dev-libs/libxml2-2.6.9
+       dev-libs/libxslt
+       >=dev-tcltk/tcllib-1.2
+       dev-libs/expat"
+#      test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+PATCHES=(
+               "${FILESDIR}"/${PN}-3.2-fix-implicit-declarations.patch
+)
+
+src_configure() {
+       local myconf=""
+
+       use threads && myconf="${myconf} --enable-threads"
+
+       econf ${myconf} \
+               --with-xml2-config="${EPREFIX}"/usr/bin/xml2-config \
+               --with-xslt-config="${EPREFIX}"/usr/bin/xslt-config \
+               --with-tclinclude="${EPREFIX}"/usr/include \
+               --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+               $(use_enable amd64 64bit) \
+               $(use_enable debug symbols)
+}