dev-libs/softhsm: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 19 Oct 2018 16:12:09 +0000 (19:12 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 19 Oct 2018 16:12:28 +0000 (19:12 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

dev-libs/softhsm/Manifest
dev-libs/softhsm/softhsm-2.5.0.ebuild [new file with mode: 0644]

index 4a3e518a95d7eca512f6d9954727ce354b712b33..3e5d79284f97c2ae82e713b20cadc1ed34ddbd1f 100644 (file)
@@ -1 +1,2 @@
 DIST softhsm-2.4.0.tar.gz 1042566 BLAKE2B 01a0f4bdc589847c4a1f860c3e3f572644d874b11d7ab8e149e598fc123b75e898de9a46f73f5f2a107edcaeabdda29e4b9b6d54af5b95ad79a3c7b7b77b8bbf SHA512 f14f65de32206500f708523ee88d8d5e3d1fd40175f1a9cd24c7760c829e2de9dbcb05453022df8186836c49a57e4eae7f2e75ce6a5346a426114f4d610a8a84
+DIST softhsm-2.5.0.tar.gz 1078439 BLAKE2B f96f9e08f3ea568daccb64a5de94ac91b5efcee3dea09f460e98491e7fcdca1277ed52c339a2ec10dac2f78c9e7e44fe5c4a7d36c58e97afba6e749979d4d7e0 SHA512 a1e686729196dc25591eb3da57c2c8ea8494ed274ba711842b2dcae696f477a202acda13a975b8fb1eb68e8e44a79e839dbbc6ba500cab02ad13072c660752d9
diff --git a/dev-libs/softhsm/softhsm-2.5.0.ebuild b/dev-libs/softhsm/softhsm-2.5.0.ebuild
new file mode 100644 (file)
index 0000000..aecd75f
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="https://www.opendnssec.org/"
+SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bindist libressl migration-tool test"
+SLOT="2"
+LICENSE="BSD"
+
+RDEPEND="migration-tool? ( dev-db/sqlite:3= )
+       !libressl? ( dev-libs/openssl:=[bindist=] )
+       libressl? ( dev-libs/libressl:= )
+       !~dev-libs/softhsm-2.0.0:0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+       sys-devel/gcc:=[cxx]
+       test? ( dev-util/cppunit )"
+
+DOCS=(
+       NEWS
+       README.md
+)
+
+src_configure() {
+       econf \
+               --disable-static \
+               --with-crypto-backend=openssl \
+               --disable-p11-kit \
+               --localstatedir="${EROOT}/var" \
+               $(use_enable !bindist ecc) \
+               $(use_enable !libressl gost) \
+               $(use_with migration-tool migrate)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+
+       keepdir "${EROOT}/var/lib/softhsm/tokens"
+}