sci-visualization/paraview: Fix compile for "development -python", bug #560670
authorMatthias Maier <tamiko@gentoo.org>
Sun, 20 Sep 2015 03:00:46 +0000 (22:00 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 20 Sep 2015 03:04:08 +0000 (22:04 -0500)
Thanks to Dion Moult for tracking this down.

Gentoo-Bug: 560670

Package-Manager: portage-2.2.20.1

sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch [new file with mode: 0644]
sci-visualization/paraview/paraview-4.3.1.ebuild

diff --git a/sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch b/sci-visualization/paraview/files/paraview-4.3.1-fix-development-install.patch
new file mode 100644 (file)
index 0000000..4bc5e54
--- /dev/null
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=560670
+http://www.paraview.org/Bug/view.php?id=15655
+
+diff --git a/Qt/Components/CMakeLists.txt b/Qt/Components/CMakeLists.txt
+index c45b4bf..8616a90 100644
+--- a/Qt/Components/CMakeLists.txt
++++ b/Qt/Components/CMakeLists.txt
+@@ -650,7 +650,7 @@ vtk_module_library(${vtk-module}
+ #the pqSGExportStateWizard has subclasses that directly access
+ #the UI file, and currently we don't have a clean way to break this hard
+ #dependency, so for no we install this ui file.
+-if(PARAVIEW_INSTALL_DEVELOPMENT_FILES)
++if(PARAVIEW_INSTALL_DEVELOPMENT_FILES AND PARAVIEW_ENABLE_PYTHON)
+   install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ui_pqExportStateWizard.h"
+           DESTINATION "${VTK_INSTALL_INCLUDE_DIR}")
+ endif()
index 7d7b44fc04e6bbed084b67070233f2699d6c0c68..c978762fd4950184409ca2b2cdf70bbc0b39deb9 100644 (file)
@@ -90,12 +90,13 @@ pkg_setup() {
 src_prepare() {
        # see patch headers for description
        epatch "${FILESDIR}"/${PN}-4.0.1-xdmf-cstring.patch \
-               "${FILESDIR}"/${PN}-4.2.0-removesqlite.patch \
                "${FILESDIR}"/${PN}-4.0.1-gcc-4.7.patch \
+               "${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
                "${FILESDIR}"/${PN}-4.2.0-protobuf.patch \
+               "${FILESDIR}"/${PN}-4.2.0-removesqlite.patch \
+               "${FILESDIR}"/${PN}-4.2.0-vtk-freetype.patch \
                "${FILESDIR}"/${P}-protobuf-2.6.patch \
-               "${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
-               "${FILESDIR}"/${PN}-4.2.0-vtk-freetype.patch
+               "${FILESDIR}"/${P}-fix-development-install.patch
 
        # lib64 fixes
        sed -i \