dev-libs/libwacom: Version bump to 1.1
authorDavid Heidelberg <david@ixit.cz>
Sun, 27 Oct 2019 15:44:27 +0000 (16:44 +0100)
committerMatt Turner <mattst88@gentoo.org>
Sun, 2 Feb 2020 02:40:51 +0000 (18:40 -0800)
- port to meson
- include two meson fixes patches from master
- add patch for optional doc/doxygen compilation option (merged upstream)

Closes: https://bugs.gentoo.org/698660
Signed-off-by: David Heidelberg <david@ixit.cz>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/libwacom/Manifest
dev-libs/libwacom/files/libwacom-1.1-configurable_docs.patch [new file with mode: 0644]
dev-libs/libwacom/files/libwacom-1.1-match-with-autotools.patch [new file with mode: 0644]
dev-libs/libwacom/files/libwacom-1.1-meson-add-private.patch [new file with mode: 0644]
dev-libs/libwacom/libwacom-1.1.ebuild [new file with mode: 0644]

index 853e050675fd77c2daa7e7be557075921cbaceee..1c34c96423c03909152c2e6d7e6faef7f8a4333e 100644 (file)
@@ -1,2 +1,3 @@
 DIST libwacom-0.33.tar.bz2 503217 BLAKE2B 034b06495209cc88e9a3131a8a23b35fdadf8bc038ff9db62d4dc05b31657d1cfbe4856cf7b1a6112c97d47bb532b664e4e59c3b00a2aebf14dfacbcac141063 SHA512 de4d9cf3b5f4d87a159ba8ee617bafce9d13b67dc23d9dc67efd57317b0df2079dd0de328bc800de47f14ee49ea82bb842e34297cef23ba336c1ddca3afa826d
 DIST libwacom-1.0.tar.bz2 502457 BLAKE2B c7de15e8e403a4778662c711a4318ffd46c65fcb895e50181b14f6f9c4169493fcd14a78bae62cfad8af0e4d762b5babb06df21ff257994b1890d5ec9078e6ef SHA512 43a8098ed06c86edc647d6a6b0ee0b465bcb6089df77fd361909271aaf5f18ae2fecfa34062fd4a9fdee6983ff1303b99636485ebde6a75a669307bd19c2b313
+DIST libwacom-1.1.tar.bz2 502696 BLAKE2B 1c2e03b00eb3b17dea2d5cd3e61afa4b7f36dcb727f07bb1cc42631febc9d1939bdd2652d6fd1f0d020815cac1f937c1daddae3019ac9aa01659442cdc8b9054 SHA512 8b63d9bad18c27f8078711408a7b79c70086cd0c64fe692ee693d53d834dff8ab45631eabd206f0dfac80d8cc86c14b5833831b1b99b06e34aacd235176d266b
diff --git a/dev-libs/libwacom/files/libwacom-1.1-configurable_docs.patch b/dev-libs/libwacom/files/libwacom-1.1-configurable_docs.patch
new file mode 100644 (file)
index 0000000..47eb27d
--- /dev/null
@@ -0,0 +1,39 @@
+From 18722d30b9eb38d0cd22609e076ad45c810f137d Mon Sep 17 00:00:00 2001
+From: David Heidelberg <david@ixit.cz>
+Date: Sun, 27 Oct 2019 20:34:55 +0100
+Subject: [PATCH] meson: make documentation a feature
+
+Nice to have for distributions, which needs to have predicable build.
+
+Signed-off-by: David Heidelberg <david@ixit.cz>
+---
+ meson.build       | 3 ++-
+ meson_options.txt | 4 ++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 8283613..be2fcb3 100644
+--- a/meson.build
++++ b/meson.build
+@@ -460,7 +460,8 @@ install_man(configure_file(input: 'tools/libwacom-list-local-devices.man',
+                          copy: true))
+ ############### docs ###########################
+-doxygen = find_program('doxygen', required: false)
++docs_feature = get_option('documentation')
++doxygen = find_program('doxygen', required: docs_feature)
+ if doxygen.found()
+       src_doxygen = [
+               join_paths(dir_src, 'libwacom.h'),
+diff --git a/meson_options.txt b/meson_options.txt
+index 1d75434..84c92bf 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,3 +1,7 @@
++option('documentation',
++       type: 'feature',
++       value: 'auto',
++       description: 'Build doxygen documentation [default=auto]')
+ option('udev-dir',
+        type: 'string',
+        value: '',
diff --git a/dev-libs/libwacom/files/libwacom-1.1-match-with-autotools.patch b/dev-libs/libwacom/files/libwacom-1.1-match-with-autotools.patch
new file mode 100644 (file)
index 0000000..06858cd
--- /dev/null
@@ -0,0 +1,24 @@
+From 07753990d7476d52cfd34fb7558c077bd8b44eeb Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Mon, 23 Sep 2019 09:29:45 +1000
+Subject: [PATCH] meson.build: match the libwacom.pc file Name with the
+ autotools one (#164)
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 13459f7..3e0cc07 100644
+--- a/meson.build
++++ b/meson.build
+@@ -81,7 +81,7 @@ dep_libwacom = declare_dependency(link_with: lib_libwacom)
+ install_headers('libwacom/libwacom.h', subdir: 'libwacom-1.0/libwacom')
+ pkgconfig.generate(filebase: 'libwacom',
+-                 name: 'Libwacom',
++                 name: 'libwacom',
+                  description: 'Wacom model feature query library',
+                  version: meson.project_version(),
+                  subdirs: 'libwacom-1.0',
diff --git a/dev-libs/libwacom/files/libwacom-1.1-meson-add-private.patch b/dev-libs/libwacom/files/libwacom-1.1-meson-add-private.patch
new file mode 100644 (file)
index 0000000..e31df3a
--- /dev/null
@@ -0,0 +1,21 @@
+From 6953c5a9fc51e286134cb977b3fdfe0999f3503a Mon Sep 17 00:00:00 2001
+From: worldofpeace <worldofpeace@protonmail.ch>
+Date: Sun, 22 Sep 2019 19:04:58 -0400
+Subject: [PATCH] meson: add private requires to .pc (#163)
+
+---
+ meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/meson.build b/meson.build
+index 0ae03e1..13459f7 100644
+--- a/meson.build
++++ b/meson.build
+@@ -85,6 +85,7 @@ pkgconfig.generate(filebase: 'libwacom',
+                  description: 'Wacom model feature query library',
+                  version: meson.project_version(),
+                  subdirs: 'libwacom-1.0',
++                 requires_private: deps_libwacom,
+                  libraries: lib_libwacom)
+ #################### data files ########################
diff --git a/dev-libs/libwacom/libwacom-1.1.ebuild b/dev-libs/libwacom/libwacom-1.1.ebuild
new file mode 100644 (file)
index 0000000..0496e24
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson udev toolchain-funcs
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+"
+RDEPEND="
+       dev-libs/glib:2
+       dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}/${P}-meson-add-private.patch"
+       "${FILESDIR}/${P}-match-with-autotools.patch"
+       "${FILESDIR}/${P}-configurable_docs.patch"
+)
+
+pkg_setup() {
+       tc-ld-disable-gold # bug https://github.com/linuxwacom/libwacom/issues/170
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_feature doc documentation)
+               $(meson_use test tests)
+               -Dudev-dir=$(get_udevdir)
+
+       )
+       meson_src_configure
+}