sys-apps/coreutils: Disable tests incompatible w/ sandbox
authorSam James (sam_c) <sam@cmpct.info>
Wed, 29 Apr 2020 10:00:59 +0000 (10:00 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 29 Apr 2020 15:21:16 +0000 (17:21 +0200)
Bug: https://bugs.gentoo.org/413621
Bug: https://bugs.gentoo.org/675802
Thanks-to: Kent Fredric
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15562
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/coreutils/coreutils-8.31-r1.ebuild
sys-apps/coreutils/coreutils-8.32-r1.ebuild
sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch [new file with mode: 0644]

index 48911f369827a09c38f55bb3cb65fadeb72fda82..007052ac9cf314abd5ed843b374da0552aafac21 100644 (file)
@@ -60,6 +60,7 @@ pkg_setup() {
 src_prepare() {
        if ! use vanilla ; then
                eapply "${WORKDIR}"/patch/*.patch
+               eapply "${FILESDIR}"/${PN}-8.31-sandbox-env-test.patch
        fi
 
        eapply_user
index d63be698dccfd3671bff35d93f7c74434bfc329c..3eac2b76aae2bc8c6afb59d0095ad708aa8c3b05 100644 (file)
@@ -71,6 +71,7 @@ src_prepare() {
 
        if ! use vanilla ; then
                PATCHES+=( "${WORKDIR}"/patch )
+               PATCHES+=( "${FILESDIR}"/${PN}-8.31-sandbox-env-test.patch )
        fi
 
        default
diff --git a/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch b/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
new file mode 100644 (file)
index 0000000..40b1554
--- /dev/null
@@ -0,0 +1,64 @@
+Skip tests known to fail when running under Gentoo sandbox.
+
+--- a/tests/du/long-from-unreadable.sh
++++ b/tests/du/long-from-unreadable.sh
+@@ -29,6 +29,9 @@
+ # unnecessarily to using FTS_NOCHDIR mode in this corner case.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ du
+ require_perl_
+--- a/tests/ls/removed-directory.sh
++++ b/tests/ls/removed-directory.sh
+@@ -19,6 +19,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+ case $host_triplet in
+--- a/tests/ls/stat-free-symlinks.sh
++++ b/tests/ls/stat-free-symlinks.sh
+@@ -17,6 +17,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+ require_strace_ stat
+--- a/tests/misc/env-S.pl
++++ b/tests/misc/env-S.pl
+@@ -30,6 +30,11 @@ $env = $1;
+ # Turn off localization of executable's output.
+ @ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
++# Skip if sandbox is enabled
++if ($ENV{SANDBOX_ACTIVE}) {
++     CuSkip::skip "Gentoo: Test known bad under sandbox (#675802)\n";
++}
++
+ my @Tests =
+     (
+      # Test combination of -S and regular arguments
+--- a/tests/rm/deep-2.sh
++++ b/tests/rm/deep-2.sh
+@@ -17,6 +17,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ rm
+ require_perl_