[app-emulation/xen-pvgrub] Use toolchain function instead of calling LD directly...
authorAlexey Shvetsov <alexxy@gentoo.org>
Thu, 13 Oct 2011 19:25:12 +0000 (19:25 +0000)
committerAlexey Shvetsov <alexxy@gentoo.org>
Thu, 13 Oct 2011 19:25:12 +0000 (19:25 +0000)
Package-Manager: portage-2.2.0_alpha67/cvs/Linux x86_64

app-emulation/xen-pvgrub/ChangeLog
app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild

index fbfe8c1337d179cfd83f052299bc7d8150996651..ff5dcb95d61cd1dbb6a82d6da071829e6edadf72 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-emulation/xen-pvgrub
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.6 2011/09/25 01:45:34 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/ChangeLog,v 1.7 2011/10/13 19:25:12 alexxy Exp $
+
+  13 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-pvgrub-4.1.1-r1.ebuild:
+  Use toolchain function instead of calling LD directly, copy fix from bug
+  #384359, fix to invoke correct compiler, copy from bug #383973, patches by
+  Ian Delaney aka idella4
 
   25 Sep 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
   xen-pvgrub-4.1.1-r1.ebuild:
index 322ff5e70f89d3fab85ddf0a600c9d1fcbe7ceb1..89bd864e2e58f6ed9779486868fd5b2851def16f 100644 (file)
@@ -1,10 +1,10 @@
 # Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild,v 1.2 2011/09/25 01:45:34 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild,v 1.3 2011/10/13 19:25:12 alexxy Exp $
 
 EAPI="2"
 
-inherit flag-o-matic eutils multilib
+inherit flag-o-matic eutils multilib toolchain-funcs
 
 XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles"
 OCAML_URL=http://caml.inria.fr/pub/distrib
@@ -91,14 +91,16 @@ src_compile() {
                append-flags -fno-strict-overflow
        fi
 
-       emake -C tools/include || die "prepare libelf headers failed"
+       emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools/include || die "prepare libelf headers failed"
 
        if use x86; then
-               emake -j1 XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || \
+               emake -j1 CC=$(tc-getCC) LD=$(tc-getLD) \
+               XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || \
                die "compile pv-grub_x86_32 failed"
        fi
        if use amd64; then
-               emake -j1 XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub || \
+               emake -j1 CC=$(tc-getCC) LD=$(tc-getLD) \
+               XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub || \
                die "compile pv-grub_x86_64 failed"
                if use multilib; then
                        multilib_toolchain_setup x86