Version bump. Use autotools-eclass. Link with gmp when cgal is built with gmp. Merged...
authorSebastien Fabbro <bicatali@gentoo.org>
Sun, 8 Jan 2012 01:32:14 +0000 (01:32 +0000)
committerSebastien Fabbro <bicatali@gentoo.org>
Sun, 8 Jan 2012 01:32:14 +0000 (01:32 +0000)
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64

sci-physics/fastjet/ChangeLog [new file with mode: 0644]
sci-physics/fastjet/Manifest [new file with mode: 0644]
sci-physics/fastjet/fastjet-3.0.1.ebuild [new file with mode: 0644]
sci-physics/fastjet/metadata.xml [new file with mode: 0644]

diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
new file mode 100644 (file)
index 0000000..f09514e
--- /dev/null
@@ -0,0 +1,16 @@
+# ChangeLog for sci-physics/fastjet
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+
+*fastjet-3.0.1 (08 Jan 2012)
+
+  08 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.1.ebuild,
+  +metadata.xml:
+  Version bump. Use autotools-eclass. Link with gmp when cgal is built with
+  gmp. Merged plugins flags into one. Initial import to the main tree.
+
+  30 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> fastjet-2.4.4.ebuild:
+  Remove unused eutils.eclass, shorten DESC, add missing license, sort
+  KEYWORDS, add static-libs, docs IUSE, add dependency on doxygen for [doc],
+  build only shared libs by default, install documentation
+
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
new file mode 100644 (file)
index 0000000..c302015
--- /dev/null
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST fastjet-3.0.1.tar.gz 2122452 RMD160 db8da72c845e9782fb2d8b796cb4e87f83f5f68e SHA1 00c2155db3ed82db36d688d0a501b6232f23c804 SHA256 4f17c235e73a6fcbc8ee39c15a00f166b701e732033e623625f55fe93220a4ed
+EBUILD fastjet-3.0.1.ebuild 1189 RMD160 61dc5985900e03ca1ea86b91e45a508c1e788b2a SHA1 6d281daf9aac1ce323c543fbe787cc76205ea54e SHA256 7d6a47d00fb7a2e29f0965bf85c1448d13c9cb3af8bbe13c4a37b4dcc20089ce
+MISC ChangeLog 770 RMD160 1d94124f6d2051e69b4b8a77c91596d4578fd8a5 SHA1 5c8f88c9045af8dc85b7731234b298e3275491a0 SHA256 347d0b432137c88ff705119fdcd2f36289653fa44e2b2b260d24beead6d8ca07
+MISC metadata.xml 770 RMD160 f6ec58006506a950fe36a8a2a761d58398e2dea1 SHA1 7d03be13f80119c6bb908c03dd820bfa33409c26 SHA256 d4b7a99b53a609ac44459ff596354b014204aed5303ed8d8d8b0ad1d6e4f2f4a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk8I8icACgkQ1ycZbhPLE2Cj3gCfd6mjLCrjv/p4WbiqKOCsc+G3
+9AkAn2Mz9KtvHAu/oGxDm0l/Yb9srqO/
+=O6Wz
+-----END PGP SIGNATURE-----
diff --git a/sci-physics/fastjet/fastjet-3.0.1.ebuild b/sci-physics/fastjet/fastjet-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..fd02fa2
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.1.ebuild,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+
+EAPI=4
+inherit autotools-utils fortran-2 flag-o-matic
+
+DESCRIPTION="Fast implementation of several recombination jet algorithms"
+HOMEPAGE="http://www.fastjet.fr/"
+SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgal doc examples +plugins static-libs"
+
+RDEPEND="cgal? ( sci-mathematics/cgal )"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )
+       plugins? ( virtual/fortran )"
+
+src_configure() {
+       use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+       myeconfargs+=(
+               $(use_enable cgal)
+               $(use_enable plugins allplugins)
+               $(use_enable plugins allcxxplugins)
+       )
+       autotools-utils_src_configure
+}
+
+src_compile() {
+       autotools-utils_src_compile
+       use doc && doxygen Doxyfile
+}
+
+src_install() {
+       autotools-utils_src_install
+       use doc && dohtml html/*
+       if use examples; then
+               insinto /usr/share/doc/${PF}
+               find example \
+                       -name Makefile -or Makefile.in -or Makefile.am -delete
+               doins -r example/*
+       fi
+}
diff --git a/sci-physics/fastjet/metadata.xml b/sci-physics/fastjet/metadata.xml
new file mode 100644 (file)
index 0000000..63f715f
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+    The FastJet package provides a fast implementation of the
+    longitudinally invariant kt longitudinally invariant inclusive
+    Cambridge/Aachen and anti-kt jet finders and a uniform interface
+    to external jet finders (notably SISCone) via a plugin
+    mechanism. It also includes tools for calculating jet areas and
+    performing background (pileup/UE) subtraction.
+ </longdescription>
+ <use>
+   <flag name='plugins'> Build all standard and C++ plugins </flag>
+   <flag name='cgal'> Use <pkg>sci-mathematics/cgal</pkg> instead of
+   bundled algorithms</flag>
+ </use>
+</pkgmetadata>
+