mail-client/hap: port to EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 9 Feb 2020 11:41:38 +0000 (14:41 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 9 Feb 2020 11:41:38 +0000 (14:41 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
mail-client/hap/files/hap-3.7-ncurses.patch
mail-client/hap/hap-3.7-r1.ebuild

index 1ae79b9e98102de18a3e97aa534c38ccce6e5999..3bd3efa3a1e4108a32fd68d4cf37de0d06f8e2af 100644 (file)
@@ -1,5 +1,5 @@
---- configure.in       1996-07-17 00:50:03.000000000 +0300
-+++ configure.in       2013-03-06 15:09:29.579148360 +0200
+--- a/configure.in     1996-07-17 00:50:03.000000000 +0300
++++ b/configure.in     2013-03-06 15:09:29.579148360 +0200
 @@ -6,8 +6,9 @@
  AC_PROG_INSTALL
  
index 54db510d8e8adfb296cc0e1e46fb52a0fedab686..168f33fc748d5209d5a773c8d22b4cc638526858 100644 (file)
@@ -1,33 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit autotools eutils
+inherit autotools
 
 DESCRIPTION="A terminal mail notification program (replacement for biff)"
 HOMEPAGE="http://www.transbay.net/~enf/sw.html"
 SRC_URI="http://www.transbay.net/~enf/${P}.tar"
 
-DEPEND="sys-libs/ncurses"
+DEPEND="sys-libs/ncurses:0="
 RDEPEND="${DEPEND}"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ppc x86"
-IUSE=""
 
 S="${WORKDIR}/${PN}"
 
 src_prepare() {
        # Fix configure to use ncurses instead of termcap (bug #103105)
-       epatch "${FILESDIR}/${P}-ncurses.patch"
+       eapply "${FILESDIR}/${P}-ncurses.patch"
 
        # Fix Makefile.in to use our CFLAGS and LDFLAGS
        sed -i -e "s/^CFLAGS=-O/CFLAGS=${CFLAGS}/" \
                -e "s/^LDFLAGS=.*/LDFLAGS=${LDFLAGS}/" Makefile.in || die
 
        # Rebuild the compilation framework
+       default
        eautoreconf
 }