dev-java/jmh-core: version bump - 1.21
authorAustin English <wizardedit@gentoo.org>
Mon, 20 Aug 2018 22:06:45 +0000 (17:06 -0500)
committerAustin English <wizardedit@gentoo.org>
Mon, 20 Aug 2018 22:11:26 +0000 (17:11 -0500)
Also some general cleanup which fixes #662862

Gentoo-Bug: https://bugs.gentoo.org/662862

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-java/jmh-core/Manifest
dev-java/jmh-core/jmh-core-1.21.ebuild [new file with mode: 0644]

index c554a55a82636e2d05400a973f8b7755e44874bd..668ef0de11ee147239c4fed77a6040a939318199 100644 (file)
@@ -1 +1,2 @@
+DIST jmh-core-1.21.tar.gz 615305 BLAKE2B 1a5cfe9784efe0cd7706382eaa89c8bcce0efcce3c2b802ce0772992dd16f0c6900a47d70b72d1c556584adb8afda442f49267ad4e0b53d04c20026979787210 SHA512 ac51d58d9b746157842a3bc9c4828bbff52c5882582e123e04b5ab6c4bfc1ff3cad1f6023ab1fe1eccfa68c73ffbd21b34388547bba544626af87092852ec166
 DIST jmh-core-1.4.1.tar.gz 585746 BLAKE2B ff6e9d3e8b11827042a9ff9983505fa5272d943a8365cf14ac43d940a7815f280c2b82c3ab810f1c22328a932912f6b09b9c5d5f1838a3cb357e6ebe21006e49 SHA512 a33c63b82712deb53218bb8d955c9606e5f393ff0c6256052ac8df022ec45be79bc0ee5ee08ce0d3762594214814bcf1e562717d83daa9ce13c664ca9e7c431b
diff --git a/dev-java/jmh-core/jmh-core-1.21.ebuild b/dev-java/jmh-core/jmh-core-1.21.ebuild
new file mode 100644 (file)
index 0000000..1d89946
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Hash of tag, download not available via ${PV}
+MY_PN="jmh"
+MY_PV="f25ae8584db1"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Harness for building, running, and analysing nano/micro/milli/macro benchmarks"
+HOMEPAGE="http://openjdk.java.net/projects/code-tools/jmh"
+SRC_URI="http://hg.openjdk.java.net/code-tools/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# jopt *must* be 4.6, see http://mail.openjdk.java.net/pipermail/jmh-dev/2016-October/002395.html
+CP_DEPEND="
+       dev-java/asm:4
+       dev-java/junit:4
+       dev-java/commons-math:3
+       dev-java/jopt-simple:4.6"
+
+DEPEND=">=virtual/jdk-1.7
+       ${CP_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.7
+       ${CP_DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/${PN}"