dev-python/pyrsistent: 0.16.0
authorSebastian Pipping <sping@gentoo.org>
Wed, 8 Apr 2020 18:37:41 +0000 (20:37 +0200)
committerSebastian Pipping <sping@gentoo.org>
Wed, 8 Apr 2020 18:41:45 +0000 (20:41 +0200)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.96, Repoman-2.3.22

dev-python/pyrsistent/Manifest
dev-python/pyrsistent/pyrsistent-0.16.0.ebuild [new file with mode: 0644]

index 88ee393d62ba83bb924069e0d89c4cda6503f185..de12596b0213e23b8dd2733ed38c6d6064a23189 100644 (file)
@@ -1 +1,2 @@
 DIST pyrsistent-0.15.6.tar.gz 107424 BLAKE2B 432ce7223fee524cbcd65237171af6f0fa16d23dfcc65b7cb5bc8d19dc8216344bf21660d2acf9b07eb1bc9b883840c0b5de679cfe52a0f977e64cea21cd584f SHA512 42b259c66e118d5b09bcc64e57441729146ed9b40e9fd18cda83c4aa0523d5bc3acde3177113e1f2a1b5c1e3a14d15b369df9701a9218a88a656ba0359b5ff10
+DIST pyrsistent-0.16.0.tar.gz 108012 BLAKE2B 62283b8ef478302964fc6b1869c3646c23b78762c5f4fad68aa239433c54d9c652544d5ce05dee18107c8f9604b689043d07f67b9396f6dce0cce3aab022e2de SHA512 d5764b1a185d4578bf308f338037e0546b06e79a3e7189b904e24e95e0e907bc98d7c1c68becc5549a541a5864df75aba6088cafa3558ecb0a63dafb22f5674a
diff --git a/dev-python/pyrsistent/pyrsistent-0.16.0.ebuild b/dev-python/pyrsistent/pyrsistent-0.16.0.ebuild
new file mode 100644 (file)
index 0000000..6a88280
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+       ${RDEPEND}
+       test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest