media-gfx/inkscape: disable the effects of USE=nls.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 21 Feb 2020 15:49:50 +0000 (10:49 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 21 Feb 2020 19:52:01 +0000 (14:52 -0500)
The upstream build system is broken with USE=nls at the moment.
Rather than drop the USE flag entirely (which might lead users to
think that it's going away) this commit comments out the resulting
-DWITH_NLS parameter that gets passed to the build system. Thus
"USE=-nls" becomes a lie, but it should begin to work again once the
upstream bug is fixed. There is a highly visible comment in the ebuild
reminding the maintainers to check on the upstream bug periodically.

Bug: https://bugs.gentoo.org/699658
Inkscape-bug: https://gitlab.com/inkscape/inkscape/issues/168
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
media-gfx/inkscape/inkscape-1.0_beta2-r1.ebuild
media-gfx/inkscape/inkscape-9999.ebuild

index 52bc56d18a54bf1802ba6f5e20d1201764fc3fe8..6350c33d33743d0dee3426d17133f8d7144224c3 100644 (file)
@@ -132,13 +132,20 @@ src_configure() {
                -DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick $(usex imagemagick)) # both must be enabled to use GraphicsMagick
                -DWITH_JEMALLOC=$(usex jemalloc)
                -DENABLE_LCMS=$(usex lcms)
-               -DWITH_NLS=$(usex nls)
                -DWITH_OPENMP=$(usex openmp)
                -DBUILD_SHARED_LIBS=$(usex !static-libs)
                -DWITH_SVG2=$(usex svg2)
                -DWITH_LIBVISIO=$(usex visio)
                -DWITH_LIBWPG=$(usex wpg)
        )
+       # We should also have,
+       #
+       #   -DWITH_NLS=$(usex nls)
+       #
+       # in this list, but it's broken upstream at the moment:
+       #
+       #  * https://bugs.gentoo.org/699658
+       #  * https://gitlab.com/inkscape/inkscape/issues/168
 
        cmake_src_configure
 }
index bc57307639b5a1f5ab889c4277397e968c18c51c..aa29d78aa48fe48927c89479985b7e4d93c5220c 100644 (file)
@@ -131,13 +131,20 @@ src_configure() {
                -DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick $(usex imagemagick)) # both must be enabled to use GraphicsMagick
                -DWITH_JEMALLOC=$(usex jemalloc)
                -DENABLE_LCMS=$(usex lcms)
-               -DWITH_NLS=$(usex nls)
                -DWITH_OPENMP=$(usex openmp)
                -DBUILD_SHARED_LIBS=$(usex !static-libs)
                -DWITH_SVG2=$(usex svg2)
                -DWITH_LIBVISIO=$(usex visio)
                -DWITH_LIBWPG=$(usex wpg)
        )
+       # We should also have,
+       #
+       #   -DWITH_NLS=$(usex nls)
+       #
+       # in this list, but it's broken upstream at the moment:
+       #
+       #  * https://bugs.gentoo.org/699658
+       #  * https://gitlab.com/inkscape/inkscape/issues/168
 
        cmake_src_configure
 }