gnome-extra/gnome-shell-extension-bluetooth-quick-connect: Extension to quickly switc...
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Mar 2020 17:51:15 +0000 (18:51 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Mar 2020 17:54:19 +0000 (18:54 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest [new file with mode: 0644]
gnome-extra/gnome-shell-extension-bluetooth-quick-connect/files/gnome-shell-extension-bluetooth-quick-connect-10-3.34.patch [new file with mode: 0644]
gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-10.ebuild [new file with mode: 0644]
gnome-extra/gnome-shell-extension-bluetooth-quick-connect/metadata.xml [new file with mode: 0644]

diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
new file mode 100644 (file)
index 0000000..7a3c303
--- /dev/null
@@ -0,0 +1 @@
+DIST gnome-shell-extension-bluetooth-quick-connect-10.tar.gz 18214 BLAKE2B 6ca20071041605c5b0a34198562b0d913d4527b2521a0f219e7533730fece41607b2270f0349f0511a6270a9f5b4f5d936247be740a6813aa9901adf3cc0fdba SHA512 5d2dab53b5377cba00743de6501259691c519dd404922bab0e500ca54bcf8942731795aff122c1669471fd3d6a51521ecea966cd2df843777ef1aa871a548772
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/files/gnome-shell-extension-bluetooth-quick-connect-10-3.34.patch b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/files/gnome-shell-extension-bluetooth-quick-connect-10-3.34.patch
new file mode 100644 (file)
index 0000000..abde8a8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/metadata.json.old        2020-03-15 18:17:50.474579697 +0100
++++ b/metadata.json    2020-03-15 18:17:57.704750038 +0100
+@@ -9,6 +9,7 @@
+     "3.26.2",
+     "3.28",
+     "3.30",
+-    "3.32"
++    "3.32",
++    "3.24"
+   ]
+ }
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-10.ebuild b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-10.ebuild
new file mode 100644 (file)
index 0000000..c0f1c95
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Allow to connect bluetooth paired devices from gnome control panel"
+HOMEPAGE="https://github.com/bjarosze/gnome-bluetooth-quick-connect"
+SRC_URI="https://github.com/bjarosze/gnome-bluetooth-quick-connect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+       dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+       net-wireless/bluez
+       app-eselect/eselect-gnome-shell-extensions
+       >=gnome-base/gnome-shell-3.26.2
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/shell-extension-}"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-3.34.patch
+)
+
+src_install() {
+       einstalldocs
+       rm -f README.md LICENSE Makefile || die
+       insinto /usr/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com
+       doins -r *
+       glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com/schemas || die
+}
+
+pkg_postinst() {
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+}
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/metadata.xml b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/metadata.xml
new file mode 100644 (file)
index 0000000..020b406
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>pacho@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>