xfce-extra/xfce4-diskperf-plugin: Bump to 2.6.2
authorMichał Górny <mgorny@gentoo.org>
Tue, 13 Aug 2019 11:18:48 +0000 (13:18 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 13 Aug 2019 12:10:40 +0000 (14:10 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-diskperf-plugin/Manifest
xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.2.ebuild [new file with mode: 0644]

index 0b76f965a2a27001421de6e0eba369063c20f2a8..7f9fc68dd3c8d15403b4100ab324fc9ebcb70b9f 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-diskperf-plugin-2.6.1.tar.bz2 338723 BLAKE2B 4bf0fa9c741e3efe276c7b00f8997ee49611809f7a19fa8bbf955cff2218c2654924f1b5a324f9d659adc02d728e451e7565c5ce457ef4a99fababe89d7a687e SHA512 ba01ec30e31db0c936b2b18df7c68883f89c6c4d5b82392759c25ef41fa89de37e2e635abd169745a9790d81af5b327768eb62ec3cc369f85e2da0bedc4c7cea
+DIST xfce4-diskperf-plugin-2.6.2.tar.bz2 347244 BLAKE2B 82ef114b6ac445627d05ed99b34f128391061e5028192aaaa47e8b87f17cb89842d541585e77da4b6ec319fc50f242fe6d1fcb510048497e2b1184a8e3dfcadb SHA512 e91a888a9936f8a0279a062801d16ebe03159df479413087a01e20c15913df781378e4b4c91ecba94d71afa813c6d3a5367b11c1c6d3d62bf10fea78c4853031
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.2.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..f1b6f09
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for disk usage and performance statistics"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}