I hate CVS
authorAndrew Ross <aross@gentoo.org>
Thu, 3 May 2007 02:49:51 +0000 (02:49 +0000)
committerAndrew Ross <aross@gentoo.org>
Thu, 3 May 2007 02:49:51 +0000 (02:49 +0000)
Package-Manager: portage-2.1.2.2

dev-db/libpq/files/libpq-7.3.19-gentoo.patch [new file with mode: 0644]

diff --git a/dev-db/libpq/files/libpq-7.3.19-gentoo.patch b/dev-db/libpq/files/libpq-7.3.19-gentoo.patch
new file mode 100644 (file)
index 0000000..254dafd
--- /dev/null
@@ -0,0 +1,54 @@
+diff -Nru postgresql-7.3.16.orig/src/interfaces/libpq/Makefile postgresql-7.3.16/src/interfaces/libpq/Makefile
+--- postgresql-7.3.16.orig/src/interfaces/libpq/Makefile       2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/interfaces/libpq/Makefile    2006-11-05 13:21:19.000000000 +0100
+@@ -18,6 +18,8 @@
+ SO_MAJOR_VERSION= 3
+ SO_MINOR_VERSION= 0
++NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
++
+ override CPPFLAGS := -I$(srcdir) $(CPPFLAGS) -DFRONTEND -DSYSCONFDIR='"$(sysconfdir)"'
+ OBJS= fe-auth.o fe-connect.o fe-exec.o fe-misc.o fe-print.o fe-lobj.o \
+diff -Nru postgresql-7.3.16.orig/src/interfaces/libpq/nls.mk postgresql-7.3.16/src/interfaces/libpq/nls.mk
+--- postgresql-7.3.16.orig/src/interfaces/libpq/nls.mk 2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/interfaces/libpq/nls.mk      2006-11-05 13:21:19.000000000 +0100
+@@ -1,5 +1,5 @@
+ # $Header: /cvsroot/pgsql/src/interfaces/libpq/nls.mk,v 1.8 2002/09/22 20:57:21 petere Exp $
+-CATALOG_NAME  := libpq
++CATALOG_NAME  := libpq-3
+ AVAIL_LANGUAGES       := cs de es fr pt_BR ru sv zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext
+diff -Nru postgresql-7.3.16.orig/src/Makefile.shlib postgresql-7.3.16/src/Makefile.shlib
+--- postgresql-7.3.16.orig/src/Makefile.shlib  2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/Makefile.shlib       2006-11-05 13:23:20.000000000 +0100
+@@ -221,7 +221,7 @@
+ all-lib: all-static-lib all-shared-lib
+-all-static-lib: lib$(NAME).a
++all-static-lib: lib$(NAME_STATIC_LIB).a
+ all-shared-lib: $(shlib)
+@@ -231,7 +231,7 @@
+ MK_NO_LORDER := true
+ endif
+-lib$(NAME).a: $(OBJS)
++lib$(NAME_STATIC_LIB).a: $(OBJS)
+ ifdef MK_NO_LORDER
+       $(LINK.static) $@ $^
+ else
+@@ -302,8 +302,8 @@
+ .PHONY: install-lib install-lib-static install-lib-shared
+ install-lib: install-lib-static install-lib-shared
+-install-lib-static: lib$(NAME).a
+-      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
++install-lib-static: lib$(NAME_STATIC_LIB).a
++      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
+ ifeq ($(enable_shared), yes)
+ install-lib-shared: $(shlib)