dev-python/setuptools: Reenable tests on py3.8
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Dec 2019 14:49:52 +0000 (15:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Dec 2019 15:13:57 +0000 (16:13 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-42.0.2.ebuild

index 4a4fdf1ae70445d538ba31d26b8950e6a293052b..9bee3995ddccbb20d78158613fe7ec3f5d6b16ae 100644 (file)
@@ -24,21 +24,16 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-# Temporary hack to avoid py38 keywording hell.  Please remove when
-# the test deps all have py38.  Also setuptools' test pass with py38,
-# so you need to hack them all in locally before bumping and test.
 BDEPEND="
        app-arch/unzip
        test? (
-               $(python_gen_cond_dep '
-                       dev-python/mock[${PYTHON_USEDEP}]
-                       dev-python/pip[${PYTHON_USEDEP}]
-                       >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
-                       dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
-                       dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
-                       dev-python/wheel[${PYTHON_USEDEP}]
-                       virtual/python-futures[${PYTHON_USEDEP}]
-               ' python2_7 python3_{5,6,7} pypy{,3})
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pip[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+               dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+               dev-python/wheel[${PYTHON_USEDEP}]
+               virtual/python-futures[${PYTHON_USEDEP}]
        )
 "
 PDEPEND="
@@ -71,15 +66,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       if [[ ${EPYTHON} == python3.8 ]]; then
-               if [[ ${PV} != 42.0.2 ]]; then
-                       eerror "Please disable py38 hacks and test locally, then update this."
-                       die "Python 3.8 support untested for ${PV}"
-               fi
-               einfo "Skipping testing on ${EPYTHON} due to unkeyworded deps"
-               return
-       fi
-
        # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
        # It tries to sandbox the test in a tempdir
        HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"