net-libs/libmicrohttpd: version bump to 0.9.44
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 2 Oct 2015 07:18:35 +0000 (03:18 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 2 Oct 2015 07:19:14 +0000 (03:19 -0400)
Package-Manager: portage-2.2.20.1

net-libs/libmicrohttpd/Manifest
net-libs/libmicrohttpd/libmicrohttpd-0.9.44.ebuild [new file with mode: 0644]

index b52117effb9da1617058cd02590f76670ebf4134..45108a01361e13ddce5e6ef4796f3bf53c6baf9a 100644 (file)
@@ -1,2 +1,3 @@
 DIST libmicrohttpd-0.9.39.tar.gz 1205722 SHA256 4f937b6065c366d776be86b1d24b8fc400ebc7ea006a9d77c49a8f2f0cd7e373 SHA512 f7a526803fd5bbd28c817836340f91569542c3f8db6f04ffc8e60cf794cd5a7f1da3beda782fa80b2f6c07bb48cd09454c5bbcae1ad81b00f0df2985740a927a WHIRLPOOL a2dc5f2303bf7fd042d9f5ca58f946e0e506232870b00d7a7cb65127cc1769fdbc9a5b12145d47d7ab4d32d48ab6b311f320c350adbc071d18aae810156073c0
 DIST libmicrohttpd-0.9.42.tar.gz 1232516 SHA256 00352073367003da40607319e4090a6a8308748b59246ae80e9871f34dad7d5b SHA512 6516f545a5b81aa23bb0d22582f6d7e7f028069d94e0d33d9d6f929e111a3c0e0432eb43b26b4eec87860e8b9f50de38f1b5e6e20cd8faf30512e4891f29b9f3 WHIRLPOOL 9d42c08ee37042debf2e16ddd244c91375e4cecb9843e08d58581a9838677148d90d469bcd4890d4a0680a62e691c659394067da1c7060f7c4e49b309be4417c
+DIST libmicrohttpd-0.9.44.tar.gz 1244988 SHA256 f2739cc05112dc00a5ebe1a470174970ca3a3fd71dcd67fb7539af9d83b8411e SHA512 4f8e679e70e95411f762615593fcf2271df542ffab2ddd89f2c435215590ffe375c8e8c1e09cc2d21389d335cad2062944d65591b9478ea26e65123ed5dd56d9 WHIRLPOOL 8cfce79be2c8c6683a8c1b5f1c2d749a6a598346b032726e4f045dda86074fc3a4b44083385a9117eab9a1f85104962aefa2c8e805bb16104e18f6e3c0646cdf
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.44.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.44.ebuild
new file mode 100644 (file)
index 0000000..738da03
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+               dev-libs/libgcrypt:0=
+               net-libs/gnutls
+       )"
+
+DEPEND="${RDEPEND}
+       test?   (
+               ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+       econf \
+               --enable-bauth \
+               --enable-dauth \
+               --disable-examples \
+               --disable-spdy \
+               --enable-postprocessor \
+               $(use_enable epoll) \
+               $(use_enable test curl) \
+               $(use_enable messages) \
+               $(use_enable ssl https) \
+               $(use_with ssl gnutls) \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       use static-libs || find "${ED}" -name '*.la' -delete
+}