x11-plugins/wmtimer: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Feb 2020 21:08:57 +0000 (22:08 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Feb 2020 21:47:31 +0000 (22:47 +0100)
Closes: https://bugs.gentoo.org/709506
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmtimer/wmtimer-2.92-r2.ebuild

diff --git a/x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch b/x11-plugins/wmtimer/files/wmtimer-2.92-gcc-10.patch
new file mode 100644 (file)
index 0000000..4332e89
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Naur wmtimer-2.92.orig/wmgeneral/wmgeneral.c wmtimer-2.92/wmgeneral/wmgeneral.c
+--- wmtimer-2.92.orig/wmgeneral/wmgeneral.c    2004-01-29 03:38:58.000000000 +0100
++++ wmtimer-2.92/wmgeneral/wmgeneral.c 2020-02-24 22:07:07.028810885 +0100
+@@ -67,6 +67,7 @@
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+ char *textColor = NULL;
+ XpmColorSymbol colorSymbols[3] = { {"Text", NULL, 0} };
+diff -Naur wmtimer-2.92.orig/wmgeneral/wmgeneral.h wmtimer-2.92/wmgeneral/wmgeneral.h
+--- wmtimer-2.92.orig/wmgeneral/wmgeneral.h    2001-10-11 07:38:39.000000000 +0200
++++ wmtimer-2.92/wmgeneral/wmgeneral.h 2020-02-24 22:06:49.756805063 +0100
+@@ -40,7 +40,7 @@
+  /* Global variable */
+ /*******************/
+-Display *display;
++extern Display *display;
+ /***********************/
+  /* Function Prototypes */
index 361f2745af0f3a6f66e0d9f98bf1afe0883103f9..f3fb9ab0ea23e0443c3a4d8dc6945f718314362c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -32,6 +32,7 @@ src_prepare() {
        cd "${WORKDIR}"/${P} || die
        eapply "${FILESDIR}"/${P}-counter-fix.patch
        eapply "${FILESDIR}"/${P}-list.patch
+       eapply "${FILESDIR}"/${P}-gcc-10.patch
        eapply_user
 }