dev-python/deprecated: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 20:28:14 +0000 (21:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 20:34:50 +0000 (21:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/deprecated/Manifest
dev-python/deprecated/deprecated-1.2.6.ebuild [deleted file]

index 613dccd32bc4a73d8849b6625baf7d907f8c034f..8c92df6b67a55d4d1beac8d2e5ad67e40d7bb0f8 100644 (file)
@@ -1,2 +1 @@
-DIST deprecated-1.2.6.gh.tar.gz 5043633 BLAKE2B cc72838dc772db62ca75637268d09cbab4c9acb84b42bd1d2d76397d43b81781cfcef075a9a6e6ca2ab55eda19acae95cdfbdd820c1363e7ea4841fb1cb61b7b SHA512 fcef322c6d9c317081dae365d469d4b26b0d23d8290e7aa0ca18592fb098ae7f535cb5e898cc81e5c734e7e211c847cdd9d5430c1999a4b9612f30934243ee9e
 DIST deprecated-1.2.7.gh.tar.gz 5044697 BLAKE2B 5e295ce21a3e536e08b6e57d78d3682b31e9041f4c53d97c06af03f8272a5b729c892449210471b80500ce499fe9e6af22df8ac0aeec5ac774fd74590ebdfc3b SHA512 da99a22410fdcc2a96cb5b15c489971078ce34e251406ae3dce6b3f97e284a4f09aaf1c5702407abe85a94cb6c8d9237f373a3096d6182e4a9cd1990be2817f1
diff --git a/dev-python/deprecated/deprecated-1.2.6.ebuild b/dev-python/deprecated/deprecated-1.2.6.ebuild
deleted file mode 100644 (file)
index 96830f8..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Python @deprecated decorator to deprecate old API"
-HOMEPAGE="https://github.com/tantale/deprecated"
-SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}