Fix configure.in so that gdome2-conf --version works correctly, thanks to Daniel...
authorCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 8 Dec 2006 18:46:52 +0000 (18:46 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 8 Dec 2006 18:46:52 +0000 (18:46 +0000)
Package-Manager: portage-2.1.2_rc2-r2

dev-libs/gdome2/ChangeLog
dev-libs/gdome2/files/digest-gdome2-0.8.1-r2 [new file with mode: 0644]
dev-libs/gdome2/files/gdome2-0.8.1-gdome2-config.patch [new file with mode: 0644]
dev-libs/gdome2/gdome2-0.8.1-r2.ebuild [new file with mode: 0644]

index fe7795d723d354bba49b666065753ef4f512efbc..36fa7c1d8b64ce0b133cafaab0806d7bcf4bfa45 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for dev-libs/gdome2
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/ChangeLog,v 1.26 2006/08/17 18:50:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/ChangeLog,v 1.27 2006/12/08 18:46:52 masterdriverz Exp $
+
+*gdome2-0.8.1-r2 (08 Dec 2006)
+
+  08 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+  +files/gdome2-0.8.1-gdome2-config.patch, -gdome2-0.8.1-r1.ebuild,
+  +gdome2-0.8.1-r2.ebuild:
+  Fix configure.in so that gdome2-conf --version works correctly, thanks to
+  Daniel Westermann-Clark; bug 114542
 
   17 Aug 2006; Jeroen Roovers <jer@gentoo.org> gdome2-0.8.1-r1.ebuild:
   Stable for HPPA (bug #144120).
diff --git a/dev-libs/gdome2/files/digest-gdome2-0.8.1-r2 b/dev-libs/gdome2/files/digest-gdome2-0.8.1-r2
new file mode 100644 (file)
index 0000000..e810262
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 bfc114e59eec50cbda8e4ece751ff022 gdome2-0.8.1.tar.gz 518965
+RMD160 5cc3ff29e0ed040e3bbd02cba4d95b9b634c4072 gdome2-0.8.1.tar.gz 518965
+SHA256 f4bb80a2ef8e5fd9397ab8aa36d059d0b32e98c4bcf185c7952a7e3874d1d543 gdome2-0.8.1.tar.gz 518965
diff --git a/dev-libs/gdome2/files/gdome2-0.8.1-gdome2-config.patch b/dev-libs/gdome2/files/gdome2-0.8.1-gdome2-config.patch
new file mode 100644 (file)
index 0000000..9e8b9bc
--- /dev/null
@@ -0,0 +1,10 @@
+--- gdome2-0.8.1.orig/configure.in     2003-10-05 10:39:27.000000000 -0400
++++ gdome2-0.8.1/configure.in  2006-01-11 13:14:37.000000000 -0500
+@@ -70,6 +70,7 @@
+       GLIB_MIN_VERSION=1.2.10
+         AM_PATH_GLIB($GLIB_MIN_VERSION,,AC_MSG_ERROR(Could not find GLIB (see config.log for details).))
+ else
++      GLIB_CONFIG="pkg-config glib-2.0"
+       PKG_CHECK_MODULES(GLIB, glib-2.0)
+       GLIB_REQUIRED="glib-2.0"
+       GLIB_MIN_VERSION=2.2.0
diff --git a/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild b/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild
new file mode 100644 (file)
index 0000000..ec1db23
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild,v 1.1 2006/12/08 18:46:52 masterdriverz Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="The DOM C library for the GNOME project"
+HOMEPAGE="http://gdome2.cs.unibo.it/"
+SRC_URI="http://gdome2.cs.unibo.it/tarball/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha ~amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.2.0
+       >=dev-libs/libxml2-2.4.26"
+
+DEPEND="${RDEPEND}
+       doc? ( >=dev-util/gtk-doc-1 )
+       dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README*"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # Fix broken GLIB_CONFIG in configure.in, see #114542
+       epatch ${FILESDIR}/gdome2-0.8.1-gdome2-config.patch
+       eautoconf || die
+
+       # make docs honor DESTDIR
+       epatch "${FILESDIR}/${P}-docs-destdir.patch"
+
+       # prevent gtk-fixxref from running (will cause sandbox violation)
+       cd ${S}/gtk-doc
+       sed -e 's:gtkdoc-fixxref:#gtkdoc-fixxref:' -i Makefile.in
+}