Initial commit.
authorSamuli Suominen <ssuominen@gentoo.org>
Mon, 9 Jan 2012 07:27:11 +0000 (07:27 +0000)
committerSamuli Suominen <ssuominen@gentoo.org>
Mon, 9 Jan 2012 07:27:11 +0000 (07:27 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

sys-apps/usbredir/ChangeLog [new file with mode: 0644]
sys-apps/usbredir/Manifest [new file with mode: 0644]
sys-apps/usbredir/metadata.xml [new file with mode: 0644]
sys-apps/usbredir/usbredir-0.3.2.ebuild [new file with mode: 0644]

diff --git a/sys-apps/usbredir/ChangeLog b/sys-apps/usbredir/ChangeLog
new file mode 100644 (file)
index 0000000..7e793e0
--- /dev/null
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/usbredir
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/ChangeLog,v 1.1 2012/01/09 07:27:11 ssuominen Exp $
+
+*usbredir-0.3.2 (09 Jan 2012)
+
+  09 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +usbredir-0.3.2.ebuild:
+  Initial commit.
+
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
new file mode 100644 (file)
index 0000000..b745eb0
--- /dev/null
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST usbredir-0.3.2.tar.bz2 292796 RMD160 bd8e2b9fcd066e322fd01a33e2fd5cc320ef319c SHA1 560121f79a79b309593f6c99a80a0979e151a1e2 SHA256 cc92c967e4396b6749be2888686f4a016f72e227278f53cc9eee21a125f2860f
+EBUILD usbredir-0.3.2.ebuild 747 RMD160 9e8674b9f606154b76b4c275ffaeccc4b7dc5028 SHA1 80edae9c28d8281af24ac4915852041bbe219d32 SHA256 21b441d9263611216ff3566dbb9ac3d6ac7825baef339f6af5bbe401cd0de1c8
+MISC ChangeLog 338 RMD160 87ed7f4e7cf63b1737b90fd668ba66e4e99b00fb SHA1 8bf0080f72b0aeaf02ef726f660c9c488a759051 SHA256 6126265af04f9d368650ae796109f37aa9d66b85c235083676d8d76135800025
+MISC metadata.xml 270 RMD160 da01208028bb208a2a3bda11d65e0c0ea7bad6cf SHA1 8db0be7c11944f76c82d875901c478c6b7746284 SHA256 ef58b1c4316d37bc29175e278d9664a16eb45869f908eb692acbd6e6f97e7da2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iQEcBAEBAgAGBQJPCpZ9AAoJEEdUh39IaPFN2yYH+gLXv3wN1xASw8AIjqp1mT5V
+yj4kpgAgTQtv2zfRftG+/ndR5MZy9PrxIBi4FIN5fLs0S6FtKp4tSJ303l/WNkHg
+dD1pp0cIzf3oDR9qGb5FOyp8jal8H96VA/3uht05xLTyyLNUa2DlpobCxYvdbSh+
+NjaiEHt+WAb8JmXyp2hryNubFu2EH1AgfFWMbM8H7GF3f2Fy94Tsyv2PaAgRtUOq
+y2Lto0LK7/bfNhlRlDW637vXETz7+4GPiCc4i5S61SjApQw3RTN71nkSxBN/1y0k
+o3PBSqs8bX3zU80O139hUL4rfxuMt3CClkdQ+UW3DKNOeMzuWqXyPcpl5yf23FE=
+=nuRO
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/usbredir/metadata.xml b/sys-apps/usbredir/metadata.xml
new file mode 100644 (file)
index 0000000..eb72a80
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>base-system</herd>
+  <maintainer>
+    <email>ssuominen@gentoo.org</email>
+    <name>Samuli Suominen</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/usbredir/usbredir-0.3.2.ebuild b/sys-apps/usbredir/usbredir-0.3.2.ebuild
new file mode 100644 (file)
index 0000000..5df3a47
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/usbredir-0.3.2.ebuild,v 1.1 2012/01/09 07:27:11 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A server and libraries for redirecting USB traffic"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+#RDEPEND="virtual/libusb:1"
+RDEPEND=">=dev-libs/libusb-1.0.9_rc"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       rm -f "${ED}"usr/lib*/lib*.la
+}