app-arch/xarchiver: Bump to 0.5.4.10
authorMichał Górny <mgorny@gentoo.org>
Thu, 29 Jun 2017 15:11:54 +0000 (17:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 29 Jun 2017 22:21:57 +0000 (00:21 +0200)
Bump to 0.5.4.10. There's also a 0.5.4.11 release but it has a build
failure that has been just fixed upstream -- there's a good chance for
a new release containing the fix soonish.

app-arch/xarchiver/Manifest
app-arch/xarchiver/xarchiver-0.5.4.10.ebuild [new file with mode: 0644]

index 234cfc5490db4f67ed8e259f5c1227df6d729b0a..e2a86394edd53502bdf777af4bd575077205be5d 100644 (file)
@@ -1,2 +1,3 @@
+DIST xarchiver-0.5.4.10.tar.gz 1011648 SHA256 bb452d8ef4eabb52ab1313b3867156ea5030b75f9e59c59c7ef487c8db9dbea4 SHA512 847ac018d0fb8b4531d0751ba5f32e902e8e8bcc66399e1f083e56605e22ccf5f7ac9b883aee7df1ab0d01db98878c6ed784c08051b4ab8f164f959d370844a1 WHIRLPOOL b733cd4fed3d2735b2d84ddd6210fc511574239c8824ad790045e7794a4d4a9ad8185fd04d444646d70a19b26f1584f89b107cf2ae889b5f67b023214e480ddd
 DIST xarchiver-0.5.4.8.tar.gz 987648 SHA256 0947dce52538876d31e18ab89270f5eb52fba2c21ce877a4d56cdb5de5048e81 SHA512 d3be46b87c9475bfde2a3449511a08b1abef3d90b0b2c0e1165e093fa54210dbc2182b986a55e12e11bed67b516732f498c8038b360df3f697603befc2a4a8b3 WHIRLPOOL ba602771a06adfda1dc5a8cf1323deb339159b9399a54f4e47d42d0e56601eb93769bb2ac58bcd39f09ceaf7de9f837d4ec91eae150d1a12fda64e509d08a273
 DIST xarchiver-0.5.4.tar.bz2 1003045 SHA256 e63fa73979fcc56efe8cca9095fd915d31a1714ce9676246b8626f164e452ef4 SHA512 3b767c2601d94104e2fc72aa8d168afa5a154b5747a9b0518d1c348417e56e4c19d872a0029fb78decc897e0f3bc9573e17d0317b85f584e7275b0e519f5f30d WHIRLPOOL 3f5a277b05147daf29db0be26718ed51fa0bb6d2416ee41cdd8ce6c54bc66064fc5f313af39a32b428997f906c9fd4d1a0b8d60fe5d2d867b1137960b0cbe4d1
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.10.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.10.ebuild
new file mode 100644 (file)
index 0000000..9cca927
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2:=
+       x11-libs/gtk+:3="
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+       doc? (
+               app-text/docbook-xml-dtd
+               app-text/docbook-xsl-stylesheets
+               dev-libs/libxml2
+               dev-libs/libxslt
+       )"
+
+src_prepare() {
+       sed -e '/COPYING/d' -e '/NEWS/d' -i doc/Makefile.am || die
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               $(use_enable doc)
+       )
+       econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+
+       elog "You need external programs for some formats, including:"
+       elog "7zip - app-arch/p7zip"
+       elog "arj - app-arch/unarj app-arch/arj"
+       elog "lha - app-arch/lha"
+       elog "lzop - app-arch/lzop"
+       elog "rar - app-arch/unrar app-arch/rar"
+       elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}