dev-util/buildbot-slave: remove last-rited package
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 07:23:41 +0000 (10:23 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 07:23:41 +0000 (10:23 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-util/buildbot-slave/Manifest [deleted file]
dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild [deleted file]
dev-util/buildbot-slave/files/buildslave.confd [deleted file]
dev-util/buildbot-slave/files/buildslave.initd [deleted file]
dev-util/buildbot-slave/files/buildslave.service [deleted file]
dev-util/buildbot-slave/metadata.xml [deleted file]

diff --git a/dev-util/buildbot-slave/Manifest b/dev-util/buildbot-slave/Manifest
deleted file mode 100644 (file)
index 0ef730f..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST buildbot-slave-0.8.12.tar.gz 118339 BLAKE2B e516a8fd212d92e1cb1ed9bc11d70aa4baaea70fd1aa7f4fa239ed1160da51b96391d252643a13a72786d0b676e0e1780d31f998da7b3f90f1b73b32adb6b6c2 SHA512 74f7f9ffab946000a5d31ae28140698ca259ba5b75815ed839d51fa5d9f702e998b61a716b66aab7946b6143d329244f2403d9b98cbbfc70223b691dcb70f0bc
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.12.ebuild
deleted file mode 100644 (file)
index 7566aa4..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 readme.gentoo systemd user
-
-DESCRIPTION="BuildBot Slave Daemon"
-HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-slave/"
-
-MY_PV="${PV/_p/p}"
-MY_P="${PN}-${MY_PV}"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/twisted-core[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       enewuser buildbot
-
-       DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
-               to support starting buildslave through Gentoo's init system. To use this,
-               set up your build slave following the documentation, make sure the
-               resulting directories are owned by the \"buildbot\" user and point
-               \"${ROOT}etc/conf.d/buildslave\" at the right location.  The scripts can
-               run as a different user if desired. If you need to run more than one
-               build slave, just copy the scripts."
-}
-
-src_install() {
-       distutils-r1_src_install
-
-       doman docs/buildslave.1
-
-       newconfd "${FILESDIR}/buildslave.confd" buildslave
-       newinitd "${FILESDIR}/buildslave.initd" buildslave
-       systemd_dounit "${FILESDIR}/buildslave.service"
-
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       readme.gentoo_print_elog
-}
diff --git a/dev-util/buildbot-slave/files/buildslave.confd b/dev-util/buildbot-slave/files/buildslave.confd
deleted file mode 100644 (file)
index 4ef42c4..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-# Path to the build slave's basedir.
-BASEDIR="/var/lib/buildslave"
-
-# User account for the buildslave.
-# The basedir should be owned by this user.
-USERNAME="buildbot"
-
-# Extra options passed to twistd.
-TWISTD_OPTS=""
diff --git a/dev-util/buildbot-slave/files/buildslave.initd b/dev-util/buildbot-slave/files/buildslave.initd
deleted file mode 100644 (file)
index 587c7cc..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
-       need net
-}
-
-checkconfig() {
-       if [ -z "${BASEDIR}" ]; then
-               eerror "BASEDIR not set"
-               return 1
-       fi
-       if [ -z "${USERNAME}" ]; then
-               eerror "USERNAME not set"
-               return 1
-       fi
-       if [ ! -d "${BASEDIR}" ]; then
-               eerror "${BASEDIR} is not a directory"
-               return 1
-       fi
-       if [ ! -e "${BASEDIR}/buildbot.tac" ]; then
-               eerror "${BASEDIR} does not contain buildbot.tac"
-               return 1
-       fi
-}
-
-start() {
-       checkconfig || return 1
-       ebegin "Starting buildslave in ${BASEDIR}"
-       # We set HOME here to make something valid show up in the env of child
-       # processes spawned by the buildslave.
-       start-stop-daemon --start -u "${USERNAME}" \
-               --pidfile "${BASEDIR}/buildslave.pid" \
-               --env HOME="${BASEDIR}" \
-               --exec /usr/bin/python -- /usr/bin/twistd \
-               --no_save \
-               --logfile="${BASEDIR}/twistd.log" \
-               --pidfile="${BASEDIR}/buildslave.pid" \
-               --python="${BASEDIR}/buildbot.tac"
-       eend $?
-}
-
-stop() {
-       ebegin "Stopping buildslave in ${BASEDIR}"
-       start-stop-daemon --stop --pidfile "${BASEDIR}/buildslave.pid"
-       eend $?
-}
diff --git a/dev-util/buildbot-slave/files/buildslave.service b/dev-util/buildbot-slave/files/buildslave.service
deleted file mode 100644 (file)
index 5c8e483..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=buildbot slave instances
-After=local-fs.target network.target
-
-[Service]
-Type=forking
-User=buildbot
-WorkingDirectory=/var/lib/buildslave
-# The following assume there is a 'slave' directory
-# in $WorkingDirectory with the slave configuration files
-ExecStart=/usr/bin/buildslave start slave
-ExecStop=/usr/bin/buildslave stop slave
-
-[Install]
-WantedBy=multi-user.target
diff --git a/dev-util/buildbot-slave/metadata.xml b/dev-util/buildbot-slave/metadata.xml
deleted file mode 100644 (file)
index e2d85b4..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <!-- maintainer-needed -->
-       <upstream>
-               <remote-id type="pypi">buildbot-slave</remote-id>
-               <remote-id type="github">buildbot/buildbot</remote-id>
-       </upstream>
-</pkgmetadata>