app-i18n/scim: Remove dep on removed qt4
authorMichał Górny <mgorny@gentoo.org>
Sat, 25 Aug 2018 20:32:12 +0000 (22:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Aug 2018 20:37:02 +0000 (22:37 +0200)
app-i18n/scim/scim-1.4.17.ebuild
app-i18n/scim/scim-1.4.18.ebuild

index 86a88efe10bb2951bc0e0149db87716f5799b902..e8653806f6b477c2b5a57a7587f7978a7436e2cf 100644 (file)
@@ -11,16 +11,12 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3 qt4"
+IUSE="doc gtk3"
 
 RDEPEND="x11-libs/libX11
        dev-libs/glib:2
        gtk3? ( x11-libs/gtk+:3 )
        !gtk3? ( x11-libs/gtk+:2 )
-       qt4? (
-               dev-qt/qtcore:4
-               dev-qt/qtgui:4
-       )
        >=dev-libs/atk-1
        >=x11-libs/pango-1"
 DEPEND="${RDEPEND}
@@ -50,8 +46,7 @@ src_configure() {
                --enable-ld-version-script \
                $(usex gtk3 --with-gtk-version={3,2}) \
                --disable-qt3-immodule \
-               $(use_enable qt4 qt4-immodule) \
-               --with-qt4-moc="$(qt4_get_bindir)/moc"
+               --disable-qt4-immodule
 }
 
 src_compile() {
index cf10edfec8e1155ceabee7ee881c5b6f67e6de06..4279a7029e83a886d91e6a98d9ab871d8cb0a4aa 100644 (file)
@@ -12,16 +12,12 @@ SRC_URI="https://github.com/scim-im/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3 qt4"
+IUSE="doc gtk3"
 
 RDEPEND="x11-libs/libX11
        dev-libs/glib:2
        gtk3? ( x11-libs/gtk+:3 )
        !gtk3? ( x11-libs/gtk+:2 )
-       qt4? (
-               dev-qt/qtcore:4
-               dev-qt/qtgui:4
-       )
        >=dev-libs/atk-1
        >=x11-libs/pango-1"
 DEPEND="${RDEPEND}
@@ -51,8 +47,7 @@ src_configure() {
                --enable-ld-version-script \
                $(usex gtk3 --with-gtk-version={3,2}) \
                --disable-qt3-immodule \
-               $(use_enable qt4 qt4-immodule) \
-               --with-qt4-moc="$(qt4_get_bindir)/moc"
+               --disable-qt4-immodule
 }
 
 src_compile() {