dev-util/idea-community: fix custom-jdk useflag in previous versions
authorKyle Elbert <kcelbert@gmail.com>
Sun, 27 Jan 2019 02:30:09 +0000 (20:30 -0600)
committerAlice Ferrazzi <alicef@gentoo.org>
Tue, 29 Jan 2019 14:58:45 +0000 (14:58 +0000)
Because of the switch to a 64 bit jdk at some point prior to even 2017.2.2 (the
oldest version in the tree), the directory naming changed and so even without
the custom-jdk useflag the jdk was being installed, and with the custom-jdk
useflag the jdk's binaries were not correctly being marked executable

Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Kyle Elbert <kcelbert@gmail.com>
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
dev-util/idea-community/idea-community-2017.2.2.172.3757.52-r1.ebuild
dev-util/idea-community/idea-community-2018.3.1.183.4588.61-r1.ebuild

index c3da3d3edc20d4691ec0e44f9336343fb1577549..bfb9c749e7037a03a400f3077586a401441f973a 100644 (file)
@@ -41,8 +41,8 @@ src_prepare() {
                rm bin/fsnotifier-arm || die
        fi
        if ! use custom-jdk; then
-               if [[ -d jre ]]; then
-                       rm -r jre || die
+               if [[ -d jre64 ]]; then
+                       rm -r jre64 || die
                fi
        fi
 }
@@ -55,8 +55,8 @@ src_install() {
        fperms 755 "${dir}"/bin/{idea.sh,fsnotifier{,64}}
 
        if use custom-jdk; then
-               if [[ -d jre ]]; then
-               fperms 755 "${dir}"/jre/jre/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+               if [[ -d jre64 ]]; then
+               fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
                fi
        fi
 
index c3da3d3edc20d4691ec0e44f9336343fb1577549..bfb9c749e7037a03a400f3077586a401441f973a 100644 (file)
@@ -41,8 +41,8 @@ src_prepare() {
                rm bin/fsnotifier-arm || die
        fi
        if ! use custom-jdk; then
-               if [[ -d jre ]]; then
-                       rm -r jre || die
+               if [[ -d jre64 ]]; then
+                       rm -r jre64 || die
                fi
        fi
 }
@@ -55,8 +55,8 @@ src_install() {
        fperms 755 "${dir}"/bin/{idea.sh,fsnotifier{,64}}
 
        if use custom-jdk; then
-               if [[ -d jre ]]; then
-               fperms 755 "${dir}"/jre/jre/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+               if [[ -d jre64 ]]; then
+               fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
                fi
        fi