app-misc/vcontrold: version bump 0.98.8
authorTobias Leupold <tobias.leupold@gmx.de>
Mon, 23 Sep 2019 17:36:46 +0000 (19:36 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 24 Sep 2019 03:39:47 +0000 (06:39 +0300)
Signed-off-by: Tobias Leupold <tobias.leupold@gmx.de>
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Closes: https://github.com/gentoo/gentoo/pull/13010
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-misc/vcontrold/Manifest
app-misc/vcontrold/vcontrold-0.98.8.ebuild [new file with mode: 0644]

index 358e60cebaa3b93a793d2e4efc838d34c04ca26f..9f910995fbac9703dc6b22121fb8929622f053f8 100644 (file)
@@ -1,2 +1,3 @@
 DIST vcontrold-0.98.5.tar.gz 86684 BLAKE2B 07ed2c932b9f1c03410cbd6c23cfbfb7bf1aeaff027f597fb6f05a6b61c647f229a75b5a87d893a66c6b8e917595083d193c5da8585c6b9546d12c5867ca1a1b SHA512 b94dbb09ffe274e0a0a0ac4948365ed3213f221dbc00ed2b2adec2ac5a632e293686d62a07575454b3d11b1b8e4e058625a067461996dd720c2f84066d57e60e
 DIST vcontrold-0.98.6.tar.gz 86999 BLAKE2B bb2933c166793a851fc9b3292cdf00228e0f5383ab6cfce66150383103e7c6b54661ef8c7f0bb177aecedef9f7ca7d3e64a20c1af106d45a6c5a1f2a32bdd971 SHA512 74c17dc83af456e9fbece44a00d775d6e474b1de76993da69f5cb897658be13a83ef2abc3fe75f571f1d52120e2ddade08079336a338af81eae8557b3b357481
+DIST vcontrold-0.98.8.tar.gz 87831 BLAKE2B cb6ac6771e087e355f909c63be480caf974632a2fc6378f6c7c461d2cd5d6f12fc0fc762a925d05af4f0ccc9252320009c3f8eee33cc026b5621ec8bcb531b72 SHA512 a3452735bc78ba4add991c03c263c1e59ae6ebfc4eb41f27136bd76c01745990b956dea17b489c6d4f088ec0d69d6f6215f2377baf78ee485e0b31642d4ae468
diff --git a/app-misc/vcontrold/vcontrold-0.98.8.ebuild b/app-misc/vcontrold/vcontrold-0.98.8.ebuild
new file mode 100644 (file)
index 0000000..67b70f6
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+RDEPEND="dev-libs/libxml2:2"
+DEPEND="${RDEPEND}
+       man? ( dev-python/docutils )"
+
+src_prepare() {
+       sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+               > "src/version.h" || die "Setting version failed"
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DMANPAGES="$(usex man)"
+               -DVCLIENT="$(usex vclient)"
+               -DVSIM="$(usex vsim)"
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       doinitd "${FILESDIR}/vcontrold"
+       insinto /etc/vcontrold/
+       doins -r xml
+}