dev-python/pytest-xprocess: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:33:35 +0000 (14:33 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:58:56 +0000 (14:58 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild [deleted file]
dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild [deleted file]

diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
deleted file mode 100644 (file)
index ca8f808..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/pytest-cache[${PYTHON_USEDEP}]
-       dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
-       # Upstream's package mistakenly includes __pycache__ directory that make
-       # tests fail.
-       rm -rf example/__pycache__ || die
-       pytest -v || die
-}
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
deleted file mode 100644 (file)
index e8c4207..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       || (
-               dev-python/pytest-cache[${PYTHON_USEDEP}]
-               >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
-       )
-       dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}]
-               dev-python/pytest-cache[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       PYTEST_PLUGINS="pytest_xprocess" py.test -v -v || die
-}