games-emulation/pcsxr: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:12:02 +0000 (18:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:20:25 +0000 (18:20 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-emulation/pcsxr/Manifest
games-emulation/pcsxr/files/pcsxr-1.9.94-disable-sdl2.patch [deleted file]
games-emulation/pcsxr/files/pcsxr-1.9.94-ffmpeg3.patch [deleted file]
games-emulation/pcsxr/files/pcsxr-1.9.94-zlib-uncompress2.patch [deleted file]
games-emulation/pcsxr/pcsxr-1.9.94-r2.ebuild [deleted file]

index 1d6c9ecd7d613aad2f4b96c0cfd55aabd4e74a8e..c0a4d7dbe8627394d4f68216de86aa22ae6b47bf 100644 (file)
@@ -1,2 +1 @@
-DIST pcsxr-1.9.94.zip 2631125 BLAKE2B 686503faffccc820bcac73bc69056ffe05176779ee49b834ce0da84c40a047b7882ca7b91a7b7f95ab153329ca6368ae545bbe567cac6a9bdba1a434c397862c SHA512 c49471c27692fbf22da32d2f5697a1dfed3dbdbfdb86cb789b0ea6cddb2a7da4f3390e4568f4e9385bf30d6baff0f2a591a80f424cf0c640cae0035ba81dce39
 DIST pcsxr-62467b86871aee3d70c7445f3cb79f0858ec566e.tar.gz 2229537 BLAKE2B 2f5c11c16d79b6747ccc5f7c655e99663a882e264548c136ff6d4b1321788a10b1475c023e0c7e0892aeb94032c522f2a0e6312e6cf66f608e1a1d7897aea809 SHA512 894e795c3616bb6abf87d144e1a2409142d457f2f2c04c4287e2804bb06caf008f42501089d555b5e43e6b2d6d2e8ac9a7d78842bed975b1b4b94465f4ed3a3c
diff --git a/games-emulation/pcsxr/files/pcsxr-1.9.94-disable-sdl2.patch b/games-emulation/pcsxr/files/pcsxr-1.9.94-disable-sdl2.patch
deleted file mode 100644 (file)
index 483ea56..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From b7864d1b8db75eda19a7601f3e2402a885bb251d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 11 Dec 2013 17:19:09 +0100
-Subject: [PATCH] Disable SDL2 check for Gentoo.
-
-The SDL2 support seems immature at the moment, so we'd prefer pcsxr
-using SDL1 even if SDL2 is installed.
----
- configure.ac | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index f79cee0..0c79cff 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -26,8 +26,7 @@ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["${GETTEXT_PACKAGE}"], [gettext domain])
- PKG_CHECK_MODULES(GLIB2, glib-2.0 >= 2.20, [], AC_MSG_ERROR([*** glib2 >= 2.20 not found!]))
- PKG_CHECK_MODULES(GTK3, gtk+-3.0 , [], AC_MSG_ERROR([*** libgtk3 >= 3.0 not found!]))
--PKG_CHECK_MODULES([SDL2], [sdl2 >= 2.0.0],
--   [AC_DEFINE([HAVE_SDL2], [1], [Use SDL2])],
-+AS_IF([true],
-    [PKG_CHECK_MODULES([SDL], [sdl >= 1.2.12],
-        [AC_DEFINE([HAVE_SDL], [1], [Use SDL])
-     ], AC_MSG_ERROR([*** SDL >= 1.2.12 not found!]))
--- 
-1.8.5.1
-
diff --git a/games-emulation/pcsxr/files/pcsxr-1.9.94-ffmpeg3.patch b/games-emulation/pcsxr/files/pcsxr-1.9.94-ffmpeg3.patch
deleted file mode 100644 (file)
index 345ed99..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/libpcsxcore/cdriso.c     2013-11-09 16:24:14.000000000 +0100
-+++ b/libpcsxcore/cdriso.c     2016-12-12 01:02:25.652521029 +0100
-@@ -266,14 +266,14 @@
-               }
-               if (!decoded_frame) {
--                      if (!(decoded_frame = avcodec_alloc_frame())) {
-+                      if (!(decoded_frame = av_frame_alloc())) {
-                               SysMessage(_(" -> Error allocating audio frame buffer. This track will not be available."));
-                               avformat_close_input(&inAudioFormat);
--                              avcodec_free_frame(&decoded_frame);
-+                              av_frame_free(&decoded_frame);
-                               return 1; // error decoding frame
-                       }
-               } else {
--                      avcodec_get_frame_defaults(decoded_frame);
-+                      av_frame_unref(decoded_frame);
-               }
-               len = avcodec_decode_audio4(c, decoded_frame, &got_frame, &avpkt);
-               if (len > 0 && got_frame) {
-@@ -285,7 +285,7 @@
-                       fwrite(decoded_frame->data[0], 1, data_size, outfile);
-               }
-               av_free_packet(&avpkt);
--              //avcodec_free_frame(&decoded_frame);
-+              //av_frame_free(&decoded_frame);
-       } while (moreFrames >= 0); // TODO: check for possible leaks
-       // file will be closed later on, now just flush it
-@@ -294,7 +294,7 @@
-       avformat_close_input(&inAudioFormat);
-       //avcodec_close(c);
-       //av_free(c);
--      avcodec_free_frame(&decoded_frame);
-+      av_frame_free(&decoded_frame);
-       return 0;
- }
- #endif
-@@ -340,12 +340,12 @@
-       while (avpkt.size > 0) {
-               int got_frame = 0;
-               if (!decoded_frame) {
--                      if (!(decoded_frame = avcodec_alloc_frame())) {
-+                      if (!(decoded_frame = av_frame_alloc())) {
-                               SysPrintf(" -> Error allocating audio frame buffer. Track will not be available.");
-                               return 1; // error decoding frame
-                       }
-               } else {
--                      avcodec_get_frame_defaults(decoded_frame);
-+                      av_frame_unref(decoded_frame);
-               }
-               len = avcodec_decode_audio4(c, decoded_frame, &got_frame, &avpkt);
-@@ -383,7 +383,7 @@
-       avcodec_close(c);
-       av_free(c);
--      avcodec_free_frame(&decoded_frame);
-+      av_frame_free(&decoded_frame);
-       return 0;
- }
- #endif
diff --git a/games-emulation/pcsxr/files/pcsxr-1.9.94-zlib-uncompress2.patch b/games-emulation/pcsxr/files/pcsxr-1.9.94-zlib-uncompress2.patch
deleted file mode 100644 (file)
index 616084b..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From dabb671947ae26942c7ef8a71fef9831e0c1884d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 26 Jan 2017 18:14:01 +0100
-Subject: [PATCH] Fix build against zlib-1.2.9+ (having uncompress2)
-
----
- pcsxr/configure.ac         | 3 +++
- pcsxr/libpcsxcore/cdriso.c | 2 ++
- 2 files changed, 5 insertions(+)
-
-diff --git a/pcsxr/configure.ac b/pcsxr/configure.ac
-index 300bb185..128b4f97 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -113,6 +113,9 @@ if test "x$have_xtest" = xno; then
-       AC_MSG_ERROR([unable to find xtest headers])
- fi
-+AC_CHECK_LIB(z, uncompress2,
-+[ AC_DEFINE([HAVE_UNCOMPRESS2], [1], [Define if libz supports uncompress2]) ])
-+
- AM_CONDITIONAL(USE_LIBCDIO, false)
- AC_ARG_ENABLE(libcdio, [  --enable-libcdio        use GNU libcdio for CD-ROM support (default=no)],
-diff --git a/pcsxr/libpcsxcore/cdriso.c b/pcsxr/libpcsxcore/cdriso.c
-index 04e866d9..fb7f28a5 100644
---- a/libpcsxcore/cdriso.c
-+++ b/libpcsxcore/cdriso.c
-@@ -1219,6 +1219,7 @@ static int cdread_sub_mixed(FILE *f, unsigned int base, void *dest, int sector)
-       return ret;
- }
-+#ifndef HAVE_UNCOMPRESS2
- static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned long in_size)
- {
-       static z_stream z;
-@@ -1249,6 +1250,7 @@ static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned lo
-       *out_size -= z.avail_out;
-       return ret == 1 ? 0 : ret;
- }
-+#endif
- static int cdread_compressed(FILE *f, unsigned int base, void *dest, int sector)
- {
--- 
-2.11.0
-
diff --git a/games-emulation/pcsxr/pcsxr-1.9.94-r2.ebuild b/games-emulation/pcsxr/pcsxr-1.9.94-r2.ebuild
deleted file mode 100644 (file)
index b58d16a..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools ltprune versionator
-
-DESCRIPTION="PCSX-Reloaded: a fork of PCSX, the discontinued Playstation emulator"
-HOMEPAGE="http://pcsxr.codeplex.com"
-# codeplex doesn't support direct downloads but GPL-2 doesn't mind me
-# mirroring it.
-SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.zip"
-
-LICENSE="GPL-2 public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="alsa cdio ffmpeg libav nls openal opengl oss pulseaudio +sdl"
-REQUIRED_USE="?? ( alsa openal oss pulseaudio sdl )"
-
-# pcsxr supports both SDL1 and SDL2 but uses the newer version installed
-# since SDL is not properly slotted in Gentoo, just fix it on SDL2
-
-RDEPEND="
-       dev-libs/glib:2=
-       media-libs/libsdl:0=[joystick]
-       sys-libs/zlib:0=
-       x11-libs/gtk+:3=
-       x11-libs/libX11:0=
-       x11-libs/libXext:0=
-       x11-libs/libXtst:0=
-       x11-libs/libXv:0=
-       alsa? ( media-libs/alsa-lib:0= )
-       cdio? ( dev-libs/libcdio:0= )
-       ffmpeg? (
-               !libav? ( >=media-video/ffmpeg-3:0= )
-               libav? ( media-video/libav:0= ) )
-       nls? ( virtual/libintl:0= )
-       openal? ( media-libs/openal:0= )
-       opengl? ( virtual/opengl:0=
-               x11-libs/libXxf86vm:0= )
-       pulseaudio? ( media-sound/pulseaudio:0= )
-       sdl? ( media-libs/libsdl:0=[sound] )
-"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-util/intltool
-       x11-base/xorg-proto
-       nls? ( sys-devel/gettext:0 )
-       x86? ( dev-lang/nasm )
-"
-
-# it's only the .po file check that fails :)
-RESTRICT=test
-
-PATCHES=(
-       "${FILESDIR}"/${P}-disable-sdl2.patch
-       "${FILESDIR}"/${P}-zlib-uncompress2.patch
-       "${FILESDIR}"/${P}-ffmpeg3.patch
-)
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       local sound_backend
-
-       if use alsa; then
-               sound_backend=alsa
-       elif use oss; then
-               sound_backend=oss
-       elif use pulseaudio; then
-               sound_backend=pulseaudio
-       elif use sdl; then
-               sound_backend=sdl
-       elif use openal; then
-               sound_backend=openal
-       else
-               sound_backend=null
-       fi
-
-       local myconf=(
-               $(use_enable nls)
-               $(use_enable cdio libcdio)
-               $(use_enable opengl)
-               $(use_enable ffmpeg ccdda)
-               --enable-sound=${sound_backend}
-       )
-
-       econf "${myconf[@]}"
-}
-
-src_install() {
-       default
-       prune_libtool_files --all
-
-       dodoc doc/{keys,tweaks}.txt
-}
-
-pkg_postinst() {
-       local vr
-       for vr in ${REPLACING_VERSIONS}; do
-               if ! version_is_at_least 1.9.94-r1 ${vr}; then
-                       ewarn "Starting with pcsxr-1.9.94-r1, the plugin install path has changed."
-                       ewarn "In order for pcsxr to find plugins, you will need to remove stale"
-                       ewarn "symlinks from ~/.pcsxr/plugins. You can do this using the following"
-                       ewarn "command (as your regular user):"
-                       ewarn
-                       ewarn " $ find ~/.pcsxr/plugins/ -type l -delete"
-               fi
-       done
-}