sys-block/fio: bump
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 13 Mar 2020 06:06:30 +0000 (23:06 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 13 Mar 2020 06:07:34 +0000 (23:07 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-block/fio/Manifest
sys-block/fio/fio-3.19.ebuild [new file with mode: 0644]

index ce2256488b88ff1d67a600963c9799eb6e134a4d..bcd89e742203edeaefb91418ee6f3dc3d190f911 100644 (file)
@@ -2,5 +2,6 @@ DIST fio-2.15.tar.bz2 545809 BLAKE2B 163530097a6ff08016c977a328bc499d052c423890c
 DIST fio-2.16.tar.bz2 558662 BLAKE2B cbc6e6000bd497fc92779c34688c0862f3adccd7c399ca5d4e4ce9ee9c40faddfec9b3fcca2fad2cd91ca00eee95c4a108273496c9e63db8017695ecf42d294d SHA512 f71c8ab8423e82ceae160bae8c17ac1222c1b2dde2ccb1b2aedb2288e0eb60485f8e9f3908640d4f6cebf166a148f4ad64026c035381c5db5141bf3059349d75
 DIST fio-3.16.tar.bz2 881436 BLAKE2B fee99930d0245474eb67ceee2d1a6ec2f1a0eb4da6d52cf8616d7eda64699a8c2727715284134fd4931e91efad69b064f66a80a78f70ea03e66d4eab4e601120 SHA512 2d651b20cbc6c7babf3adc082dbe78e1f7de920764653cf5ffd99df7516cf6190ffefe2152d2739326d3102949d9bad7db978ff88866cfa54020f9ec3b0a2a23
 DIST fio-3.17.tar.bz2 888795 BLAKE2B 10277efb1234708aff336fc3c0723d0b9b5c903dce3a999ea2b8749b5034c778be4828549b9e0d9fc36a4f9429ca86ac0011f0c110e1a44ed3ad33b6e4a30a68 SHA512 27dba4c3e8f544c0fd40a5f42660f64f42e114e7b56199bc70f540b1a09b9dec9291e3fbae0fab9691189fa4a1f40edbcf4f9b53c313fd9c1a8ba0fdbb7f524e
+DIST fio-3.19.tar.bz2 902391 BLAKE2B 84993717248add335a77c6fc03fa730f628806e1e001078d48a91bc5ac9703e42c6cc5c720cfe76a83d1daf4af2245bfd78fd6a871611de1c19562ca70a9cc89 SHA512 0004dbaf5a8ce4f2b13114a3bfb65c388bb6d01e9a82791208ff7e7eb54cd6741e60cc8cb0a19f6319301ee2040c03862725943972ea767e6cc65fce4a2b3ecb
 DIST fio-3.2.tar.bz2 613565 BLAKE2B e721d698338dd8d2c6215780a2d9a10c643a5912d3c27b3e759b4c14585ae1afe4edab5bdc54df8cf19c6f3727f8f4b19ce9da3298a5f0ef3753a5d8f423f4ef SHA512 97ea5ed6587d1e7382a67ab7ad933b6e332ba84cb648d17dcebad3c95c9eb6b1c04a4537e3470f890607f2921da77fcd4e49079b8b78f2d15e9c199dab850d1e
 DIST fio-3.7.tar.bz2 629354 BLAKE2B 99a1c88481c7a693e31b1a0bc23bc80e85df92385f9d5a7de8d6479be8bc425326a20d794eb4809f822adfcd06e07c66ebed321faa9dbae7a2c1d3c766a6467d SHA512 b1f5cb35fe1c06e030c570959ab9a96d936f9eaa2f7f30d5a34f34fd93fae057da07c4084a06143cd5188ad6b2cc06b564484f8867e050cfeddc0ee3fb0fe266
diff --git a/sys-block/fio/fio-3.19.ebuild b/sys-block/fio/fio-3.19.ebuild
new file mode 100644 (file)
index 0000000..bc57b7b
--- /dev/null
@@ -0,0 +1,146 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit python-r1 toolchain-funcs
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="https://brick.kernel.dk/snaps/"
+SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="aio curl glusterfs gnuplot gtk libressl numa python rbd rdma static tcmalloc zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       libressl? ( curl )
+       gnuplot? ( python )"
+
+BDEPEND="virtual/pkgconfig"
+
+# GTK+:2 does not offer static libaries.
+LIB_DEPEND="aio? ( dev-libs/libaio[static-libs(+)] )
+       curl? (
+               net-misc/curl:=[static-libs(+)]
+               !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+               libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+       )
+       glusterfs? ( sys-cluster/glusterfs[static-libs(+)] )
+       gtk? ( dev-libs/glib:2[static-libs(+)] )
+       numa? ( sys-process/numactl[static-libs(+)] )
+       rbd? ( sys-cluster/ceph[static-libs(+)] )
+       rdma? (
+               sys-fabric/libibverbs[static-libs(+)]
+               sys-fabric/librdmacm[static-libs(+)]
+       )
+       tcmalloc? ( dev-util/google-perftools:=[static-libs(+)] )
+       zlib? ( sys-libs/zlib[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+       gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+       static? ( ${LIB_DEPEND} )"
+RDEPEND+="
+       python? (
+               ${PYTHON_DEPS}
+               $(python_gen_any_dep 'dev-python/pandas[${PYTHON_USEDEP}]')
+       )
+       gnuplot? ( sci-visualization/gnuplot )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/fio-2.2.13-libmtd.patch
+)
+
+python_check_deps() {
+       has_version "dev-python/pandas[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+       default
+
+       sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
+
+       # Many checks don't have configure flags.
+       sed -i \
+               -e "s:\<pkg-config\>:$(tc-getPKG_CONFIG):" \
+               -e '/if compile_prog "" "-lz" "zlib" *; *then/  '"s::if $(usex zlib true false) ; then:" \
+               -e '/if compile_prog "" "-laio" "libaio" ; then/'"s::if $(usex aio true false) ; then:" \
+               configure || die
+}
+
+src_configure() {
+       chmod g-w "${T}"
+       # not a real configure script
+       # TODO: pmem
+       set -- \
+       ./configure \
+               --disable-optimizations \
+               --extra-cflags="${CFLAGS} ${CPPFLAGS}" \
+               --cc="$(tc-getCC)" \
+               --disable-pmem \
+               $(usex curl '' '--disable-http') \
+               $(usex glusterfs '' '--disable-gfapi') \
+               $(usex gtk '--enable-gfio' '') \
+               $(usex numa '' '--disable-numa') \
+               $(usex rbd '' '--disable-rbd') \
+               $(usex rdma '' '--disable-rdma') \
+               $(usex static '--build-static' '') \
+               $(usex tcmalloc '' '--disable-tcmalloc')
+       echo "$@"
+       "$@" || die 'configure failed'
+}
+
+src_compile() {
+       emake V=1 OPTFLAGS=
+}
+
+src_install() {
+       emake install DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir="${EPREFIX}/usr/share/man"
+
+       local python2_7_files=(
+               "${ED}"/usr/bin/fiologparser_hist.py
+               "${ED}"/usr/bin/fiologparser.py
+       )
+       local python_files=(
+               "${python2_7_files[@]}"
+               "${ED}"/usr/bin/fio_jsonplus_clat2csv
+       )
+       if use python ; then
+               sed -i 's:python2.7:python:g' "${python2_7_files[@]}" || die
+               python_replicate_script "${python2_7_files[@]}"
+       else
+               rm "${python_files[@]}" || die
+       fi
+
+       local gnuplot_python2_7_files=(
+               "${ED}"/usr/bin/fio2gnuplot
+       )
+       local gnuplot_files=(
+               "${gnuplot_python2_7_files[@]}"
+               "${ED}"/usr/bin/fio_generate_plots
+               "${ED}"/usr/share/man/man1/fio_generate_plots.1
+               "${ED}"/usr/share/man/man1/fio2gnuplot.1
+               "${ED}"/usr/share/fio/*.gpm
+       )
+       if use gnuplot ; then
+               sed -i 's:python2.7:python:g' "${gnuplot_python2_7_files[@]}" || die
+               python_replicate_script "${gnuplot_python2_7_files[@]}"
+       else
+               rm "${gnuplot_files[@]}" || die
+               rmdir "${ED}"/usr/share/fio/ || die
+       fi
+
+       # This tool has security/parallel issues -- it hardcodes /tmp/template.fio.
+       rm "${ED}"/usr/bin/genfio || die
+
+       dodoc README REPORTING-BUGS HOWTO
+       docinto examples
+       dodoc examples/*
+}