media-plugins/kodi-game-libretro: 1.1.0 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:04:30 +0000 (17:04 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:16:29 +0000 (17:16 -0400)
Bug: https://bugs.gentoo.org/688474
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-game-libretro/Manifest [new file with mode: 0644]
media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.0.ebuild [new file with mode: 0644]
media-plugins/kodi-game-libretro/kodi-game-libretro-9999.ebuild

diff --git a/media-plugins/kodi-game-libretro/Manifest b/media-plugins/kodi-game-libretro/Manifest
new file mode 100644 (file)
index 0000000..1e8e87c
--- /dev/null
@@ -0,0 +1 @@
+DIST kodi-game-libretro-1.1.0.tar.gz 101454 BLAKE2B 8fcd65c8221b0ec4d24a41361eebcf1a144906e86b46749625462d507ca2813b6fdd0cb63ef0fcbe29b1f11039dc5b9cdf3d24eae788e4c275200c93855eed7b SHA512 80cc868d57d4284085a7cd736930da6f1b2440cbd8667a20634c329c282e7f0b79158d4d510504a230427fae4d84d9ae29c7a76fab5e2a23820bfa72d75a8e91
diff --git a/media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.0.ebuild b/media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..54e2423
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/kodi-game/game.libretro"
+SRC_URI=""
+
+case ${PV} in
+9999)
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.git"
+       inherit git-r3
+       ;;
+*)
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro-${PV}-${CODENAME}"
+       ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       =media-libs/kodi-platform-18*
+       =dev-libs/libplatform-2*
+       "
+RDEPEND="
+       ${DEPEND}
+       "
index 89eef4973a0e3ccee81e3431083d35d76eb849d7..5f5c3e528872d210b467822206c574ff598627e5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -17,8 +17,9 @@ case ${PV} in
        ;;
 *)
        KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://github.com/kodi-game/game.libretro/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       S="${WORKDIR}/game.libretro-${PV}"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro-${PV}-${CODENAME}"
        ;;
 esac
 
@@ -27,8 +28,8 @@ SLOT="0"
 IUSE=""
 
 DEPEND="
-       =media-tv/kodi-9999
-       =media-libs/kodi-platform-9999
+       ~media-tv/kodi-9999
+       ~media-libs/kodi-platform-9999
        =dev-libs/libplatform-2*
        "
 RDEPEND="